Mercedes SLK World banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Been having trouble with the car running rough. Seemed worse at top revs. Struggle to get over 100mph. Cleaned maf and top end was better, could get up to top speed again, but still running rough. But after maf clean would start to stall at idle. Replaced mag with Bosch and runs much better. Top whack ok, no stall but still slightly rough. Starts fine, no lights. Runs smooth till you hit the gas hard. Ran the individual and got p0301 - misfire in cylinder 1. Guess I should start looking at the spark plugs. Can I swap the spark plugs around and see if the error code moves with the plug? Same goes for the coil if plug doesn't change anything. And if still no change should I go for the CPS? Or the 02 sensor. Any advice gratefully received
 

·
Administrator - Founding Member since 2006
Joined
·
93,473 Posts
When I had that error it was the cps crank position sensor
how many miles you got?
quick and cheap fix

Move plug from 1 to 2
move injector from 1 to 3
move ignition wire from 1 to 4
if still error, move coil from 1 to 2
if still error
replace cps :D
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
104k miles. And I had it serviced a couple of years back and they changed all the plugs, so I don't think it'll be just the plug - unfortunately. CPS is what I'm erring towards. Good to know that I can swap all those elements around - that is exactly what I wanted to know. Much appreciated. Will report back.
 

·
Registered
Joined
·
55 Posts
I had a misfire on cylinder 1, car ran rough. Turned out to be a fuel injector. Fairly easy job to replace, and it cured the rough running problem. 114,000 miles at the time.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Gonna swap things round at the weekend, as Mr Banks suggests. Narrow down or eliminate plugs, coil, and injector. And move on from there. The odd thing is if you reset the system, ie turn ignition off and on (even while moving, if enough momentum) the engine runs fine again. Thanks for all the responses. Very useful.
 

·
Administrator - Founding Member since 2006
Joined
·
93,473 Posts
after 3 engine restarts, cel goes away but stays stored because issue not currently happening until next time
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Thanks for all the replies. First time using odb. What is the difference between logged and pending faults. I have p0301 logged. And notice there is a pending code p0700. But I don't have any cel on.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top