Mercedes SLK World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
Was driving along for 15+ miles doing about 70+ when i put my foot down to overtake when the car just lost power. Felt like it had gone into limp mode, but there were now warning lights or any odd noises or smoke.
Didnt want to rev past 2.5K & felt like the charger had gone? Totally gutless???

Whilst sat in layby, tickover was very lumpy & wouldnt rev to the limiter.

Anyway, got the AA out to me while i parked up for 1/2 hour & then it was ok.

He couldnt Diagnostic it as it had the old round socket. So followed me hom & it was fine. Went to work today & again was fine.

AA guy suggested it might be the MAF sensor, so anyone else had this issue?

99 plate SLK230 ;-)

Also, why is the LIM light partially dim/on? It disappeared this morning for 1st time since i had it, but came back when i came home?
 

·
Premium Member 2002 SLK230K
Joined
·
17,144 Posts
Sounds like your AA guy set you in the right direction, clean the MAF. Also have a look at the K40, the pre facelift models had solder joint issues.
 

·
Registered
Joined
·
3 Posts
On my 2000 slk230 I was having loss of power at times. I could bring it on just about every time I pushed the accelerator (racing start/passing) all the way to the floor. At first it seemed to be a guessing game on what to replace since it wasn’t producing codes. But I stomped it and made it go into limp mode and then had them read for codes....bad accelerator sensor. Repaired. Just hoping to help someone who may be suffering.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,378 Posts
On my 2000 slk230 I was having loss of power at times. I could bring it on just about every time I pushed the accelerator (racing start/passing) all the way to the floor. At first it seemed to be a guessing game on what to replace since it wasn’t producing codes. But I stomped it and made it go into limp mode and then had them read for codes....bad accelerator sensor. Repaired. Just hoping to help someone who may be suffering.
Thanks

but this thread is 5 years old

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Florida!

First please update your vehicle (model?: 32, 43, 200, 230, 250, 280, 300, 320, 350, 55) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t. This takes about 30 seconds to do.

Follow exactly to update: ‘Usercp’ at the top of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘vehicle’. Info in your garage does not update your profile.

Join the gang! Your 1st thread should be your introduction so we can welcome you properly so post an introduction in the ‘New members introduce yourself here’ section. Click this: http://www.slkworld.com/new-members-introduce-yourself-here/


On a smartphone: http://www.slkworld.com/new-members-introduce-yourself-here/330737-how-update-your-profile-post-intro-smartphone.html

If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable or to ‘edit’, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members as we welcomed you to obtain your needed posts to PM/edit. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment or use the 'quote' button so we know who you are asking or replying to or referencing.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
http://www.slkworld.com/vehicle-data-card/67706-free-how-get-free-datacard.html

Thank you
Jeff
Founding Member/Super Moderator
 
1 - 4 of 4 Posts
Top