Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hey everybody,

First post on here besides the new member introductory one. I just bought my 230 last week knowing I'd have to put some work into it, so if you guys can help me with any of these things it'd be awesome. Sorry in advance for how long it'll probably be..

1. First up (and biggest issue for me at the moment), the Speedometer and odometer aren't working. Tachometer still works fine, exterior thermometer, clock and everything else on the cluster seem to be okay, and if I hold in the knob for a second I get a wrench symbol with the number "10000." three lights on the right of the cluster are on: BAS/ESP, Emergency brake, and ABS. Check engine light is also on on the left side of the cluster.

When I bought the car the previous owner told me it had stopped working about two weeks prior, and when the speedometer quit on him, all the lights immediately turned on too. and he took it to a MB Mechanic who scanned the car and told him the rear left ABS sensor needed to be replaced. apparently (from what i was told,) the hydraulic cylinder in the left side of the trunk is leaking (also needs to be rebuilt or replaced) and it leaked down into the abs sensor and shorted it. Previous owner had already ordered the part and today it came in and he gave it to me. I replaced the sensor today, and I'm really disappointed now because the problem hasn't gone away. The car seems to be driving fine, nothing weird is happening. Is there anything obvious that could be causing this to happen?


2. Next up, What's the typical operating temperature for the car? It seems to be running a little warmer than I'd expect it to. It'll jump to about 85 deg C at its highest and then back down to 80-82ish. I just bought some coolant today (zerex g-05), and I'm going to add some to the radiator just to be safe. If it keeps up i'll replace the thermostat and go from there.



3. The rearview mirror. (Might be a stupid question lol) It's not really a huge deal, it's not bothering or hindering me from driving at all, but it seems a little strange. Is it supposed to look like this, and if not, what happened? Almost looks as if Someone tried to tint the bottom half of the mirror.



4. Noticed a day after I'd bought the car that there wasn't any windshield wiper fluid in it. I opened up the hood and filled up the tank, and sure enough... after a minute of two I noticed I was standing in a puddle.

I'm guessing the crack/leak on the fluid reservoir is high up on it, since as of right now there's still fluid in there and it fires out onto the windshield. It's something I'll end up replacing soon though.. I just can't see where the actual reservoir is. It'd be awesome if someone could direct me in the right direction.

That's about all I can think of at the moment, I'll add to this if anything shows up. Any and all help is greatly appreciated. I'm still really happy with this car, the one little gripe I've had is the cup holders and how I can't fit a soda bottle in them. Lol although since it sits right about the center console I'm almost afraid to put anything that could drip up there anyway.

Thanks again!
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
3. Do a search on rear-view mirror in the R170 section. It's the self-dimming feature that is defective and you see the fluid. There's a place in the mid-west that sells the replacement unit, IIRC.

4. Do a search on windshield washer reservoir. There's photos of it in the R170, but need body panel removal for access and replacement, IIRC.
 

·
Registered
Joined
·
320 Posts
Also, that operating temperature seems normal to me. Both my 320 and my brothers 230 operate in a similar range.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
3. Do a search on rear-view mirror in the R170 section. It's the self-dimming feature that is defective and you see the fluid. There's a place in the mid-west that sells the replacement unit, IIRC.

4. Do a search on windshield washer reservoir. There's photos of it in the R170, but need body panel removal for access and replacement, IIRC.
Thanks, I'll probably hold off on a replacement mirror for now, it's not bothering me so much.

And that's an odd place to put the reservoir, i'll get on that.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
Also, that operating temperature seems normal to me. Both my 320 and my brothers 230 operate in a similar range.
That's good to hear! When I realized the coolant tank was full already I was a little worried.
 

·
Registered
Joined
·
116 Posts
work

I replaced the head gasket and radiator cap and thermostat and after about 250 mile drive from storage last night I can attest in 75 deg. weather the 2000 slk 230 runs a very solid 85 deg. Didn't budge more than 1 or 2 tops.

If it's under a a 100 you're probably good.


Mirror info is below. Email Cathy:
CC: [email protected]
Exchange pricing is as follows:
US Residents: $79 + S/H

We do require your defective mirror be returned to us once you have received
a functioning mirror. A pre-paid return service label is provided for
residents of US, Canada & Mexico only

-Front and rear views of the mirror-the mirror must be removed from the
windshield in order to obtain these photos.
-The plug, pins, and any wires
-The mounting bracket located on rear of the mirror.

Please make sure these photos are clear and in focus.

Do not open the black casing surrounding the mirror as this will cause
 

·
Registered
Joined
·
239 Posts
Hello and welcome
Temperature looks about right.
I think the fault codes have to be cleared for the lights to go out.
You can access the reservoir buy removing the wheel arch liner, only a few nuts holding it on but you have to take the wheel off.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #8
Hello and welcome
Temperature looks about right.
I think the fault codes have to be cleared for the lights to go out.

Will clearing the codes allow the speedometer to work as well as putting the lights out?And if so, Do I need an OBD scanner to clear them or is there another way with these cars?
 

·
Registered
Joined
·
239 Posts
I don't think there is a way to clear the error codes without plugging in to STAR. Maybe an OBD scanner would work. Someone else on the forum might have the definitive answer. Don't know if the speedo problem is linked but STAR could certainly identify the fault.
 

·
Registered
Joined
·
56 Posts
For me it seems that the mirror is half dark because of the rear wind protector... not an issue...

And over topping the wash tank leads to a puddle - happened to me. Capacity is 7 litres.
Maybe check headlight washing system. A leakage perhaps?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #12
For me it seems that the mirror is half dark because of the rear wind protector... not an issue...

And over topping the wash tank leads to a puddle - happened to me. Capacity is 7 litres.
Maybe check headlight washing system. A leakage perhaps?
When I tried to use the wiper fluid the first few times absolutely nothing came out of the windshield washers, but I do remember accidentally spraying the headlights when I was playing with the buttons. After that I only added about half a gallon before noticing the puddle, so I want to say it couldn't have been at 7 liters by that point. I'll check it soon though!

Also, I've noticed that when I do use the headlight washers, the driver side washer comes out, sprays the headlight, and then gets stuck outside the small door. (not sure if that really makes sense so I'll post a picture later to better illustrate what i mean.) Is that common and is there a fix?

And.. adding on to my issues, I just realized that my cigarette lighter doesn't work when plugging in a charger for my iPhone. Is there a fuse or some other reason it wouldn't be working? I plan on installing a different head unit that will play and charge my iPod/iphone so i guess it won't make much of a difference eventually.... but until then, I'd like a way to charge my phone while playing music through the stock system.
 

·
Registered
Joined
·
320 Posts
OBD Code reader should be able to clear the codes. I know it works with my brother's 98, I haven't had to clear any codes on my 01 yet.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top