Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered 2009 SLK300
Joined
·
54 Posts
Discussion Starter · #1 ·
2003 slk 230. 127K. had been having an intermittent starting problem. a few weeks ago, car wouldn't start. all the dash lights go on, but no attempt to turn over. tried it about 5-6 times, finally started. last week, same thing, but it took 25-30 attempts to get it started. should mention that this is a daily driver, so a lot of times it did start.
after the 2nd event, with a little bit of research, i figured/guessed that it was time to replace the notorious K40. ordered one, don't have it yet. due to arrive on monday.
Today, left to go to work, stopped for breakfast, came out, no start again, but this time was different -- no dash lights, car was completely electrically dead, and would not restart. called triple a, got hauled home. measured voltage at the battery, 12.7 volts.
car was still dead, and i needed to get into trunk. dash release dead, and when i put the key in the trunk lock, it won't turn. Tried spraying inside the lock cylinder, no luck.

next step was to take portable battery pack and backfeed electric into system thru OBD port under dash. This caused the dash lights to come on for a split second, but then immediately go dead again.
then i disconnected the battery for a few seconds to allow car to re-set. hooked battery back up. had full power and car started right up.

so, the question is.....am I on the right track with the k40 or should i be thinking something else?
 

·
Registered 2009 SLK300
Joined
·
54 Posts
Discussion Starter · #3 ·
yes, i have read a lot about the solder joints being repaired......but the only soldering i do is with a torch and copper pipes.....i'm not an electronics guy
 

·
Registered
Joined
·
267 Posts
Obvious way to tell if it's the K40 is the following for normal start:

1. Turn key & listen to fuel pump prime
2. dash lights on
3. It starts

K40 issue:

1. Turn key & no fuel pump prime noise
2. Dash lights still come on
3. Rad fan suddenly goes full tilt in "protect" mode (It thinks car is overheating)
4. Car will not start

Temp fix:

1-2-3-4 as above
5. Turn off all power uses (radio, heater etc) to stop battery drain
6. Let the car sit & run the protect mode, could take 5 mins?
7. Eventually the fan will slow & go off
8. At this point it should start as normal

Other than that (to get you home) K40 relay soldering is recommended.
Also don't bother buying 2nd hand ones as they may well have the same issue.

Mine does this about once every month or two, which is down from twice weekly since i re-soldered.
 

·
Registered 2009 SLK300
Joined
·
54 Posts
Discussion Starter · #5 ·
I installed a new OEM type K 40 a couple of days ago. So far, no more problems in starting, but its early.

I open the old one up, to me, even with a magnifying glass, the solder joints look ok.

New problem is that by disconnecting the battery, the bas esp dash warning light stays on. Got to research that a bit now.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top