Mercedes SLK World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
391 Posts
Discussion Starter #1 (Edited)
Started my car after a month idle today. The indicators aren't flashing, they just switch on and stay on. Same with the hazard lights (I read somewhere that switching on the hazard lights can reset the system, it didn't). Also checked the fuse (number 3 if I am correct), but that was fine. They do flash when the alarm is set. Ideas? A faulty indicator relay? Where is this located?

Edit: Was thinking of trying this - http://www.benzworld.org/forums/r170-slk-class/1355156-slk-indicator-lights-staying-possible-fix.html. Will get some WD40 in there.

Edit 2: Seems to have fixed itself, hmm...
 

·
Registered
Joined
·
8 Posts
I am having the same problem - its on and off. Sometimes it flashes and works and sometimes it doesnt. It also seems to be affecting my reverse and brake lights. I recently changed my brake light but my brake light indicator is still on in the dashboard and the brake is still not working. I checked the fuses and all looks ok. Any ideas?
 

·
Registered
Joined
·
7 Posts
This is a common problem but unfortunately it appears to have a number of causes such as the issue with the rear lights (which was the subject of a recall in the USA), a sticky relay in the control module and others. I had it and eventually traced it to a dry joint on the fuse holder for the turn-signal fuse.

Check out the following links:


http://www.benzworld.org/forums/r170-slk-class/1524413-turn-signal-_-turn-signal-relay.html


http://www.benzworld.org/forums/r170-slk-class/1355156-slk-indicator-lights-staying-possible-fix.html


Peter
 

·
Registered
Joined
·
10 Posts
This is a common problem but unfortunately it appears to have a number of causes such as the issue with the rear lights (which was the subject of a recall in the USA), a sticky relay in the control module and others. I had it and eventually traced it to a dry joint on the fuse holder for the turn-signal fuse.

Check out the following links:


http://www.benzworld.org/forums/r170-slk-class/1524413-turn-signal-_-turn-signal-relay.html


http://www.benzworld.org/forums/r170-slk-class/1355156-slk-indicator-lights-staying-possible-fix.html


Peter
This worked for me, great info plus photos of the module, hardest part was having the nerve to start .!
 

·
Registered
Joined
·
10 Posts
Hi,

This maybe an old post, but I just wanted to add my experience;

I drive a 1998 230K.
Indicator lights stopped blinking. They just stayed ON.
Solution to the problem (in my case) was:
- Turn the engine off
- Then push the Hazard switch. Lights will blink as expected.
- Turn Hazard lights off.

- Turn the key in the ignation (contact on) and try the indicator lights. On my car everything worked again.

Note that pushing the Hazard switch with the contact on resulted in ALL indicator light turning on, but not blinking. And not solving the problem.

Regards,
Ruud
 

·
Registered
Joined
·
10 Posts
Update:
Ultimately the "solution" using the hazard switch no longer worked.
What did work was replacing the indicator relais in the comfort module 170 820 09 26. The relais is open-frame and soldered in.
The alternative is getting a replacement comfort module. They are occasionally offered for a decent price on ebay.

Regards,
Ruud
 

·
Administrator 2009 SLK 55 AMG/Founding member 2006
Joined
·
94,146 Posts
Thanks for the update...4 years late but still appreciated :D
 
1 - 7 of 7 Posts
Top