Mercedes SLK World banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Ok


I don't know how I can work on this thing (sk230) when I can't figure out how to use this forum..to many things going on around me, I guess...but anyway


Apparently the previous owner installed an aftermarket radio the only thing I can think is it is wired incorrectly along with the vacuum pump problems but one thing at a time, but here's the problems


1) no alarm
2) no remote locking...but the lights flash with the key & doors lock upon driving & unlock when I open the drivers door including trunk
3) the lock and anti tow control on the console don't work* this is where I think some of the ignition problem comes from...I tried to lock the car with it and then the car wouldn't shut off...maybe coincidence...?


to shut the engine down:
first loosen NEG battery cable...because you will have to disconnect it immediately after you pull the ignition fuse because the switch is in the run position and everything goes crazy... fans lights etc.
last time I left the cable of and fuse out till I replaced the switch and everything worked fine once I reconnected everything


The hardest part is removing the ignition lock assembly to remove the switch... and very time consuming to remove all the dash panels and instrument cover without breaking them...that's $500 worth of parts...ask me how I know that...NO DON'T...but mine were cracked when I got it..


I replaced the brake light switch last week pretty straight forward & I'm waiting for a tensioner pulley because that went bad along with the ignition switch... at least it wasn't the water pump... as I thought...!


Does anyone know where I can find a wiring diagram for the ignition switch and/or radio, lock and tow switch...and just how much can I do before the car locks me out and won't start..? THAT'S MY BIGGEST FEAR


I love the way it handles when it runs ( I know you don't like the noise from the sport comp 2 but they stick to the road really good)...but it doesn't seem to be running much...I might have bit off more than I can chew on this one and it's my only vehicle.. and can't afford another one shame on me...!


any help with the wiring diagrams would be greatly appreciated...and help to read the response would be great too...what do you want from a retired pipefitter/welder..????


thanks for your help


Harry
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,100 Posts

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,129 Posts
None of your symptoms align exactly with the usual symptoms but if you're comfortable doing so, remove the K40, disassemble it, and re-flow all the solder joints on the PCB. You don't need to remove or add any solder, just melt the solder on each connection for a second or two.

A STAR scan might reveal additional helpful information.

You have a confusing set of symptoms, and I'm guessing you have multiple issues. Disconnecting the battery while the car is running cannot be healthy for the electronics.
 

·
Registered
Joined
·
82 Posts
I say leave K40, PCB and all that stuff alone for now. You don't know that that's where the problem lies and if you mess up with soldering there you might be left with a bus ticket.


Tackle one problem at the time.
Did you already replace the ignition switch? If not, check the wires with voltmeter/test light to see if any are hot/dead when they shouldn't be (so check all of them in all key positions). My guess, one is hot at all times when it shouldn't be. That can happen if wires get hot, insulation melts and 2 wires get shorted. It can be inside the switch or somewhere else.


As for alarm, this is probably related, as the car might not turn the alarm on when it thinks it is still running. Do dome lights and the trunk light work? They share fuse 9 with the alarm (I think).
 

·
Premium Member 2001 SLK200K/2001 SLK320
Joined
·
2,076 Posts
It'd be nice if people would come back with a conclusion to threads that they started to let us know what happened next, did it ever get fixed? if so, what was it? etc. etc. doesn't happen enough but there we go. It's not just this forum but pretty much every forum, car related or otherwise.

It's about now lol that Jeff dives in with his "this thread's over two years old, 04 slk230 hasn't been here since last August, here's a few links to to help you to avoid posting in old threads .. "
@jbanks15 :D
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,100 Posts
It'd be nice if people would come back with a conclusion to threads that they started to let us know what happened next, did it ever get fixed? if so, what was it? etc. etc. doesn't happen enough but there we go. It's not just this forum but pretty much every forum, car related or otherwise.

It's about now lol that Jeff dives in with his "this thread's over two years old, 04 slk230 hasn't been here since last August, here's a few links to to help you to avoid posting in old threads .. "

@jbanks15 :D
We have a new mini me!!! :D
My limit for nagging varies.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,100 Posts
Not that old. 2017...good for a few chuckles :D
 
1 - 9 of 9 Posts
Top