Mercedes SLK World banner

1 - 15 of 15 Posts

·
Registered 2005 SLK200
Joined
·
12 Posts
Discussion Starter #1
Hello everyone, I came across a weird problem. My car idles high even when it's at proper working temperature. I changed thermostat recently (it was stuck open and car wouldnt get to operating temp). I noticed that the car idles higher after fast driving (up to 1500rpm). Anyone has any idea what it could be? Thank you in advance!
 

·
Administrator/Founding Member since 2006
Joined
·
100,476 Posts
is the idle rough or even?
 

·
Registered 2005 SLK200
Joined
·
12 Posts
Discussion Starter #3
It's actually even. it stays put, for example 1300rpm, and may drop back to 800 after 30 seconds (but not always, there are times it stays high for the whole time im at the traffic light for example)
 

·
Registered 2005 SLK200
Joined
·
12 Posts
Discussion Starter #4
if it drops, it drops veeery slowly, during a period of 30-45 seconds, thats what i meant
 

·
Administrator/Founding Member since 2006
Joined
·
100,476 Posts
the experts will chime in
 

·
Registered 2005 SLK200
Joined
·
12 Posts
Discussion Starter #7
Hello i860 and thanks for the reply. ALL codes are deleted, did that some days ago. I thought the same as you did, however nothing changed. I was thinking about any vaccum leaks or something, maybe some tube? I dont really know the car's physiology yet as I only have it for like a month.
 

·
Registered 2005 SLK200
Joined
·
12 Posts
Discussion Starter #9
unfortunately i dont have access to DAS, my mechanic uses a professional system but its not DAS. any way to inspect supsicious/common components?

otherwise i ll have to visit a dealership unfortunately...
 

·
Registered 2004 SLK200
Joined
·
622 Posts
I'd start with checking the surroundings of the accelerator pedal. Carpets, dirt, hinges, there is a plastic pin that looks like it can cause problems, check if the pedal springs back as it should.
 

·
Registered 2005 SLK200
Joined
·
12 Posts
Discussion Starter #13
Do you think its likely to be the pedal? I thought i d have more problems with that... I will check though!! thanks racing_green
 
1 - 15 of 15 Posts
Top