Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
111 Posts
Discussion Starter · #1 · (Edited)
My car is not starting. I already replaced the spark plugs and cleaned the injectors, but my guess is that the problem is the fuel pump. The code reader gave me the following codes:
P0455
P0410
P0105
P0460
P0201
P0202
P0203
P0204

If someone can guide me and tell me what these codes mean and help me identify the real problem, i would really appreciate it. Thanks!
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #4 ·
The relay looks fine, i ordered a new Bosch fuel pump and fuel regulator, i will install it next week and let everyone know if this solves the issue. The car was having trouble starting, then it doesn't start anymore. The pump is delivering no pressure, i read that it could be because of the Fuel Filter, i don't think i have ever replaced the fuel filter so that might be the problem.. however the injectors were quite dirty, so i'm gonna change the filter, the pump and the fuel regulator. I hope this will take care of the problem.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #8 ·
UPDATE: The car is not starting or sometimes having intermittent starts; i'm replacing the existing K40 with a new one tomorrow. I'll keep you guys updated. I really hope this fixes the problem. Also, do you guys think there could be a connection between the roof not functioning and a faulty k40?
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #10 ·
Update: Replaced the old k40 with a new one today and everything seems to be solved. No more codes on the scanner. The ASR light is still on and the roof still doesn't work but that must be something unrelated. The car is starting and running perfectly now.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #14 ·
Doesn't it have a light or something?
Try pressing it to see if the ASR light goes out.
It doesn't have a light, it just says asr off and nothing happens if i press it. However i tried to "turn it off" tonight and the windows rolled down when i pressed the roof switch, wich usually doesn't happen, so the asr might be the root of the problem.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #15 ·
New update: the intermittent starts are back. A check engine light came
Up a few days ago but everything was working fine. Last night, the car didn't want to start. I had filled Up a full gas tank a couple of hours before; same thing as when the problems first began. Today, i turned it on and it started without a problem. What could be going on here? This is becoming a nightmare.
 

·
Registered
Joined
·
111 Posts
Discussion Starter · #16 ·
UPDATE: The alternator is not working properly, it was draining the battery. After cleaning all the contacts and charging the battery, the car starts fine and the vario roof is finally working once again after months of being dead. I ordered a new alternator and will install it week.
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top