Mercedes SLK World banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
95 Posts
hello :
so to simplify the problem that i`m having thing of old carbs and when you want to purge them by choking them with ur hand for a sec (((at least that's the way i remember it was done i never owned one myself for a LONG time :> ))) anyways that sound of the engine choking and dying that's what i have with mine every few secs or mins its irregular i will post a video of it now but keep in mind that the video shows it in a good mood...

www.youtube.com/watch?v=BORuJanp4uQ



now what i did so far is :
1-i bought a new MAF
2- i took everything after the MAF apart looking for air leaks and nothing
3-i installed new rubber seals for fuel injectors
4-new spark plugs new wires for those too
5-i checked for codes and the only code that came was the air flap regulator ((wire was unplugged so its a no go there too))
6-i changed the fuel pump(original used)+new BOSCH filter and nothing
7-took out the K40 and resoldered the heck out of it a few weeks before so its not that
8-checked for water on the sparks and they looked all blacked out so i guess there was no water on them + no water is missing from the rad so the head gasket is intact !??


now as for symptoms when driving :
when driving only when i want to accelerate its at its worst even if i floor it i would get like 5 sec delay then move at the same speed as if i let my foot off the brakes ... and give it another 5~10 secs and it will start to move as if i hit the gas for like just the smallest amount

it started with a very small hesitation on the start as i use to make the wheels lose slip on the start you know when nobody's looking i liked to let it lose a bit ^^ but it started as NOPE start slow/clean and the BAM power and go then i lost the BAM then the power then even the go ... mind you if i get it to speed i can cruise at high speeds as high as 160kmh so HELP PLEASE did i lose my car ?
 

·
Registered 2002 SLK320
Joined
·
239 Posts
Did you replace the MAF with a genuine MB one? The cheap ones found on sites like eBay don't always work and fail prematurely. Try unplugging the MAF running the engine, if the engine runs better on tick over it points to a faulty MAF.
 

·
Registered
Joined
·
361 Posts
as AYCEE said.
maf may be new but still no good.
can you find a good one to borrow ( off a mates car) or put yours on a mates car to prove it is ok?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top