Mercedes SLK World banner

Status
Not open for further replies.
1 - 20 of 27 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
so the reason im here is i need help figuring out some thing and maybe fixing them on my own :

1- the kick down wont work at all maybe a small kick down maybe i say .
2- the car stalls its like when some one hits brakes the gas all the time if i left my foot of the pedals .
3- when i was looking around i accidentally cut a wire (it was broken and i was trying to move it away from the body metal when it snaped ) WHAT IS IT ?? photos are in attachment .
4- there is a plug laying around and i was wondering what is it for ? and some kind of air tube is unplugged too !
photos are in attachment .
5- there is this strange sound that comes every few mins some times more on the driver side behind the tire its like when you sound a Japanese horn when you have a dead battery i think its some kind of pressure release of some kind :S

thanks in advance .
the one i broke off !



the lose wire.





..now here is my story :
i went to a shop and got the car checked before buying it ! engine was 70% (no blue some thank god) gear box had a slight delay in 3rd gear they said it had oil leaks between the gear/engine (( i cut down from the price to fix it)) thats about it . i parked the car went to finish the sale got to my car drove it for 5 min AND ALL HELL BROKE LOSE !! smoke came from every were i parked and i called to get it picked . the next day the gear box wouldn't change from first 50% of engine oil was out . so when i got it checked the gear box had mixed water with oil so i had it rebuild as for the oil leaks all kind of leaks were fixed too and i paid 50% of the car price just on fix`s now the car runs but its VERY rough and un smooth there is no power and the kick down would not work radio is locked the roof was working now it wont open all the time the tires are shoot other than that its fine ........
 

Attachments

·
Registered
Joined
·
119 Posts
vacuum

attach vacuum line back to the changeover solenoid ( the one in the picture you asking whats this) make sure it is tight vacuum hose
 

·
Registered
Joined
·
25 Posts
Actually pretty minor things from the looks of it. The broken connector is from the camshaft adjustment solenoid and it's connector. Not sure about the dealers in Kuwait but it's covered under a "silent" recall or service campaign here and they just replaced mine along with the connector last week for free. The vacuum hoses will sometimes work loose and just need to be reconnected.
 

·
Registered
Joined
·
25 Posts
Even if they don't cover it, the camshaft solenoid is about $60 US and the harness extension is about $12 and it takes less than 20 minutes to do and is quite easy. I would have done myself had it not been for the recall.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #10
Even if they don't cover it, the camshaft solenoid is about $60 US and the harness extension is about $12 and it takes less than 20 minutes to do and is quite easy. I would have done myself had it not been for the recall.
is it a must do right now kinda of a thinggy ? coz i really dont have the time to go fixy fixy on stuff :S ? and i think when i get the time i will go and give the old code reader a try my car just dont run as it should its like when you press the gas and re move you feet from it like 1-2 a sec and its sluggish it only runs fast if i down shift my self and even then its nothing special .... why did i bought this car is just beyond me ......
 

·
Registered
Joined
·
25 Posts
I don't think it will hurt things not fixing right away but a defective (or as it is now unplugged) camshaft solenoid will certainly hurt performance and cause what you describe.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #12
I don't think it will hurt things not fixing right away but a defective (or as it is now unplugged) camshaft solenoid will certainly hurt performance and cause what you describe.
dont remind me of that :< the pizza car won over me from red light QQ but hey at least i can hit 200 easy well it is slow to 200 but i can do it :p
 

·
Registered
Joined
·
95 Posts
Discussion Starter #13
im starting to think my engine is now the 230 !! one of the meca told me the engine was changed :S and i think its the smaller one !! or it might be the performance issue from the camshaft :S im not sure anymore QQ ... is there a way to tell ??
 

·
Registered
Joined
·
95 Posts
Discussion Starter #14
im going to upload a vid to youtube showing how the car acts now :S today i was going to work and i was kinda in a harry and i pressed the gas i was doing 140 kmh when the car started to act weird :S it wouldnt go pass 80kmh and it was uber slow to the point i had to open the hazered lights to let ppl know that i cant move fast :S when i parked i pushed the pedal to rev the engine it wouldnt go pass 2-3k rpm :S i tried to move it around it was sooo jerky i was moving around in the car like a ball !! from starting point the car took like 10 sec to make it to 30kmh and if i didnt press any thing from stopping point the car would just jerky around . it like if i pressed the gas hard and removed my leg of it many times per sec :S i hope the vid shows it all it is at night :S im going to get the car to a dealer with a device to check the codes the car gives !! im going to fix it now !!! i hate my live now ......
 

·
Registered
Joined
·
95 Posts
Discussion Starter #15
im going to upload a vid to youtube showing how the car acts now :S today i was going to work and i was kinda in a harry and i pressed the gas i was doing 140 kmh when the car started to act weird :S it wouldnt go pass 80kmh and it was uber slow to the point i had to open the hazered lights to let ppl know that i cant move fast :S when i parked i pushed the pedal to rev the engine it wouldnt go pass 2-3k rpm :S i tried to move it around it was sooo jerky i was moving around in the car like a ball !! from starting point the car took like 10 sec to make it to 30kmh and if i didnt press any thing from stopping point the car would just jerky around . it like if i pressed the gas hard and removed my leg of it many times per sec :S i hope the vid shows it all it is at night :S im going to get the car to a dealer with a device to check the codes the car gives !! im going to fix it now !!! i hate my live now ......
this is the vid
 

·
Registered
Joined
·
95 Posts
Discussion Starter #17
i did the K40 realy and the car runs ok now its not jerky anymore BUT there is no power at all i can hardly make 120kmh and the supercharger is on from idol but at least its some what smooth now . more thoughts ??
 

·
Premium member 2009 SLK55 AMG
Joined
·
4,926 Posts
Is there nothing you can work out with the people that obviously sold you a car with major engine defects? It sounds like this car was patched together so it might run acceptably just long enough to sucker someone into buying it during a test drive.
 

·
Registered
Joined
·
579 Posts
Is there nothing you can work out with the people that obviously sold you a car with major engine defects? It sounds like this car was patched together so it might run acceptably just long enough to sucker someone into buying it during a test drive.
Don't you hate people like this??

Good luck, I know Mercedes are great until they have electrical problems. Btw, I spy a cts-v coupe in that video :biglaugh:
 

·
Registered
Joined
·
34 Posts
Are u sure your kompressor is working?!
Without the vacum connection and reconnected camsphaft selenoid, it woud be in CHECKENGINE...and won't work properly on 100 %!
 
1 - 20 of 27 Posts
Status
Not open for further replies.
Top