Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 4 of 4 Posts

·
*Registered
1999 SLK230
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys,

So my 1999 SLK 230 was making a loud whinning noise whether it was in park, neutral, or accelerating. It was also not shifting any gears. I assumed this was Limp Mode because of low transmission fluid. The O ring harness connector went bad which caused a leak and I dont believe this right amount of trans fluid was put back in. Anyway, I got a scan done and this is what it showed:

Human body Rectangle Font Violet Magenta



At first I thought the Solenoid fault codes (P0753 to 743) were caused by the low transmission fluid. I did a transmission flush and put in 8 quartz but no luck, the noise is still there and it is not shifting gears. My mechanic believes its a bad transmission oil pump causing the noise since it is starving for fuel. But im thinking its the solenoids. Wouldn't bad solenoids cause the restricting of transmission fluid to the oil pump causing it to starve and make the noise? Also, wouldn't there be a separate code if the transmission pump went bad?

Other symptoms of the car: It wont shift gears, only stuck in one gear, whinning noise, will only drive for a little bit but then gets stuck and wont move (it will rev but wont move) and when you turn the car off and turn it back on after a few seconds it works again but again only for a short time, shifting between P-R-N-D is harsh.

Any help would be appreciated! Heres a video of the noise:

 

·
*Premium Member
2005 SLK55 AMG /2005 SLK350
Joined
·
6,751 Posts
I would start with a second hand tcu, but clean the wire harness and connector before reinstalling. is the foam where the wire harness enters the foot well stained with tranny fluid?
 

·
*Registered
Joined
·
641 Posts
I would start with the ABS issues! No matter what you do the ABS readings are bad for the car. Until they are checked/gone you will face trouble.
There is a HUGE helper:

Edit:
Christmas Lights on the dash = 99% K-40.
 

·
**Premium Member '02 R170 SLK V8 5.0 & '00 SLK320
Joined
·
8,093 Posts
Not what you want to hear, but I'd rather give you a factual answer than see you go off replacing parts you don't need to.

The Transmisson is goosed.

I would start by removing the Transmission Pan and Filter, cut the Filter open, I'll bet it's chokka block with debris because the Transmission has been driven to death with low Fluid level and an ABS Fault.

Yes the ABS Fault will prevent it from Shifting, the Whining is Pump Cavitating due to starvation of Fluid because the Filter is choked with all manner of excessively worn Transmission parts due to it being driven with low Fluid Level ...............

It doesn't take long to destroy an Auto Trans as it slips like a mother when run with low Oil ;)

BTW, you should be using SDS as nothing else actually works properly and reads all of circa 13 Computers on R170 :p
 
1 - 4 of 4 Posts
Top