Mercedes SLK World banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi all,

So our SLK230 has been standing downstairs in the garage for quite a while (about a month) without being driven. Then today we went down to take her out and lone behold the car won't start.. Everything seems fine, turning the key all the check lights come on and everything. Then when the key is rotated to start, the engine cranks over constantly but does not start. What could this be? How could we go about fixing this?

In the past the car battery had run flat because I left the lights on (doh!) but we managed to recharge it fine and drove it after that and it seemed to work fine. Fast forward a month or two later and now this :(

Thanks in advance!
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,450 Posts
Time for a new battery. get it tested
 

·
Premium Member 2004 SLK200K
Joined
·
10,758 Posts
Try jump starting with another car , if it goes - new battery ! Our Slks are very delicate on the battery side of things !
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,450 Posts
but that does not resolve your issue. it will happen again. bad battery, bad cells, bad cables, corrosion, loose attachments
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
but that does not resolve your issue. it will happen again. bad battery, bad cells, bad cables, corrosion, loose attachments
Could've been just fuel stuck in the system that needed some pushing. Don't think it's a battery issue.
 

·
Registered
Joined
·
29 Posts
Are you starting okay now? I have just gone through merry hell with all this too, engine cutting out .... K40, CPS, Battery.... All changed and as it was an intermittent, at the MB Stealer too, so it cost a bloody fortune.:tazz:
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top