Mercedes SLK World banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hello to all, I'm new owner to MB world. I picked up a 98 e320 from a local here in Fl. The low coolant level light came on and goes off and on. Checked levels , seemed ok and no leak found. engine temp seems to heat up fairly quickly and stays between midway and just slightly higher when at stop light. Any ideas on what could be wrong? (Tstat,level idicator)
 

·
Sadly Woolly has passed away
Joined
·
17,375 Posts
Welcome from NE England. One of the R170experts is sure to answer soon, and await JB's instructions!!
 

·
Registered
Joined
·
5,134 Posts
Welcome from Blighty.... :)

e320.... ?? Hmm, may well be some folks here that can help, but this is primarily an SLK site. You're still welcome to stick around and contribute etc.... :)
 

·
Premium Member 2002 SLK230K
Joined
·
17,144 Posts
Not sure about the e class but I would have a look at the windscreen reservoir it may be on the same circuit like the R170's'

Welcome
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,349 Posts
Pete,

Welcome from Valrico, Florida!
And welcome to this great forum!

Please update your location/vehicle (model and yr) in your profile as it helps the members answer any questions you might have based on locale and model and year.
Usercp at the top of page, edit your details, location/vehicle.






If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.
If you wish to PM (Private Message) someone, you need 15 posts. To get those 15 posts quickly, just go to the ‘new members introduce yourself here’ section and welcome enough new members listed to obtain your needed posts.
And finally, if you find something useful on your visit here today, perhaps something that saved you time or money, please consider becoming a donating member or make a one-time donation to offset development and operating costs. Even $5 is welcome! At the top of the page, click ‘Donate now’. Thanks!
 

·
Registered
Joined
·
843 Posts
hello to all, I'm new owner to MB world. I picked up a 98 e320 from a local here in Fl. The low coolant level light came on and goes off and on. Checked levels , seemed ok and no leak found. engine temp seems to heat up fairly quickly and stays between midway and just slightly higher when at stop light. Any ideas on what could be wrong? (Tstat,level idicator)
I am guessing you copied and pasted your MBworld post to our forum here on SLKworld. If you haven't done so already, you might also want to see if the Benzworld.org E-class guys can help you out.

Not sure if your low level circuitry is the same as R170's of the same approximate age, but as suggested already, I would actually check the windshield wiper fluid level and add fluid to that reservoir as needed.
 
1 - 9 of 9 Posts
Top