Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I am glad to be a part of SLKWorld.com and look forward to becoming an active participant in some of these fascinating discussions.

Earlier this year my wife decided she needed to get rid of her stodgy Honda and bought a 2001 SLK 320 Sport with about 90K on the odometer. Practical it is not, but we have had a lot of fun "touring" around in it.

Some things I am particularly interested in... Since we bought it, the blower motor failed (I replaced it), the central locking system has malfunctioned and the car wouldn't start for a few days (then mysteriously healed itself), and a few other things. Overhead light stopped working, high beams stopped working, windshield washer stopped pumping, a couple of dash lights have gone dark, and periodically the marker lights come on and can't be turned off.
:surprise:
So I'm eagerly sifting through various threads in an attempt to find out possible reasons for some of these things... My goal is to at least keep pace with the rate of component failure by actually repairing something. And if by chance I get something working I'll pass along my learning!
 

·
Founding Member 2006
Joined
·
108,849 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Registered
Joined
·
49 Posts
Hello and welcome from Maryland. Sounds like you may have several different issues going on, you come to the right site to get info on SLK's. Sorry I have a (R170) 99 230 so I'm not an expert on your model but their are many members in SLK world that are. Good luck and enjoy your SLK.
 

·
*Premium Member
2005 SLK55 AMG
Joined
·
11,537 Posts
Hi and welcome from the UK Midlands! :)
 
  • Like
Reactions: GFM

·
*Premium Member
2009 SLK55 AMG
Joined
·
14,633 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!

Where in Nor. California do you live? We have 2 SLK car groups, 1 in the Bay Area & 1 in the Sacramento area. We do drives, meets and lunches. We send out emails to notify all our members about upcoming events. Be sure to check out the events here on SLKWORLD.see links below.

https://www.facebook.com/groups/SVSLK/
http://www.slkworld.com/u-s-california/

Feel free to call me or email
 

·
Premium Member
Joined
·
351 Posts
Hi and welcome to SLK World from Southern England.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #15 ·
Lil Don,

Thanks much for the heads-up. I reside in San Jose, i.e. "the Bay Area." I see a lot of these driving around here - or else I am sensitized to this particular vehicle because I drive one. It really is a blast, plus I'm always interested to wake up in the morning and find out what stopped working last night!

Regards,

Gary
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #16 ·
Thanks for the tip!

Yes, I do seem to come across the famous PSE pump a lot. Apparently it is responsible for some of the most unexpected modes of failure... I disassembled mine and, sure enough, discovered some long-term water damage. The board was corroded and some IC pins looked questionable.

Strange thing is, it never rains here (this is California, after all) and the car worked perfectly the day we bought it! So I believe it might be the PSE, but the price of these things is preposterous... I'll keep checking and maybe I'll get lucky.

Regards,

Gary
 

·
Premium Member 2014 SLK55 AMG
Joined
·
902 Posts
Welcome from Southern Maryland!
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top