Mercedes SLK World banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
I posted a while back about an unusual problem with my gas pedal. It worked fine except that it would go into limp mode if I put the roof down.I 'd restart and it would be fine. I tested this many times and it indeed was the case as confirmed by a MB specialist who also reset the sensors in my roof when it wouldnt go down after winter.

So I was fortunate to find a pedal on ebay for £50 but also a R171 for £25. So I mailed the guy and asked him iof he's accept £25 for the R170. He did! :biglaugh: Anyway, fitted it today and problemo solved but noticed that it's very slightly different on what looks like the disengage/kickdown (mines a manual) for the cruise control. The newer one did'nt have the connection for the plug, just seems to be a dummy switch. No problem- just swapped them over but anyone know why that is? Mines the 320 so is this maybe off something else?
 

Attachments

·
Registered
Joined
·
35 Posts
I have a '02 2 litre kompressor, 6 speed manual, and I have had a look at my accelerator for interest. Turns out that it DOES have a wired in switch, described on a diagram as a "kickdown switch" (p/n S16/6), in place of the thing in your photo. It is fully connected up to the main loom, but I am mystified as to why it is there, as I assume it is only of use in an automatic transmission set-up. :eek:
 

·
Registered
Joined
·
110 Posts
Discussion Starter #5
I have a '02 2 litre kompressor, 6 speed manual, and I have had a look at my accelerator for interest. Turns out that it DOES have a wired in switch, described on a diagram as a "kickdown switch" (p/n S16/6), in place of the thing in your photo. It is fully connected up to the main loom, but I am mystified as to why it is there, as I assume it is only of use in an automatic transmission set-up. :eek:


Yup- thats what I have too... I think it to overide the cruise when you have it in the mode where you still use the accelerator pedal yet it cuts out above the speed you set on the lcd screen. The cruise has two modes. The pic shows the blank/dummy that was in my replacement pedal.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top