Mercedes SLK World banner

Status
Not open for further replies.
1 - 20 of 29 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
OK, so I just installed the Smarttop in my '99 R170. I won't go into the poor instructions, but I finally got it to work. Kinda. And I can't seem to find another thread that answers my issue.

Windows go up and down just fine, using either the fob or the console button. Top? Not so much. When I try to do it the old fashioned way, holding the console button back, it just flashes. No top movement. And yes, it was working just fine before the Smarttop install.

Sigh.

I'm going to re-check my re-check on the wires ... but has anyone had this issue?

Thanks.

- Rick
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
do not hold the console button, just flick it once, what happens?
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
What Jeff and Jon said, do not press and hold (not even half-a-second, or it thinks you want to open the OEM-MB way), just one quick click (mouse-click quick). Does the roof operate using the remote key?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
To all ... nothing happens. Nada. Zip.

Using either the fop or the switch, a double tap does the windows fine. A single tap on the console or a triple tab on the fob does zip.

I tried holding the switch because that should the the MB way, right? Well, it just flashes like I've got the trunk cover undone --- which I don't. Top worked perfectly just prior to the install. :-(
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
To all ... nothing happens. Nada. Zip.

Using either the fop or the switch, a double tap does the windows fine. A single tap on the console or a triple tab on the fob does zip.

I tried holding the switch because that should the the MB way, right? Well, it just flashes like I've got the trunk cover undone --- which I don't. Top worked perfectly just prior to the install. :-(
Not familiar with the SmartTOP for R170.

Double check the wiretaps, its connection to the connectors and color of the wires to which it's supposed to tap into. Double check one wire at a time and use a pencil/highlighter to place check mark against each connection on the printed install instruction sheet.

Last resort is to email for help from mods4cars.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
Update --- removed and reattached all wires. Same thing. I did notice the center console light flashes slowly a couple of times, then does this double-heartbeat thing 4-5 times, then stops. This is when I single flick the console switch with the engine on, or triple click the fob.
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
Update --- removed and reattached all wires. Same thing. I did notice the center console light flashes slowly a couple of times, then does this double-heartbeat thing 4-5 times, then stops. This is when I single flick the console switch with the engine on, or triple click the fob.
Is the trunk lid separator engaged to allow roof to retract?
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
Yep. The top went up and down just prior to the install. It's not the top. It's the smarttop, somehow.
Try to inactivate the SmartTOP following the recommended (programming) procedure, wait for 3-5 minutes, reactivate or enable smartTOP and see what happens.

Firmware is up to date, I presume.

Try the center console button to operate the roof with the engine running.

I've one occasion where it was a faulty module.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Try to inactivate the SmartTOP following the recommended (programming) procedure, wait for 3-5 minutes, reactivate or enable smartTOP and see what happens.

Firmware is up to date, I presume.

Try the center console button to operate the roof with the engine running.

I've one occasion where it was a faulty module.
What a good idea. And now I'm even more puzzled.

Disabled the Smarttop. Tried to use the switch as normal. Nada. Re-enabled (and yes, firmware is up to date). Same behavior as before.

So now I'm thinking something happened when I cycled the top just prior to install!

A new symptom --- turning the engine on and pulling back on the console button is still a no-go. But when I push and hold it, I hear motors cycling for about 3-4 seconds, stop, and then nothing. Now, I've not tried to push the button forward before after the top was raised, so I don't know if this is normal or not.

I also retracted the cargo cover in the truck to see what would happen. Didn't change a thing. So either something is happening before that microswitch is tested, or my switch went on me at exactly the right (wrong) moment.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
i remember that someone did not have it programmed right or did not save the programming upon exit to enable the smarttop to enabled.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #13
Hmmm, I have an idea what it may be. Too dark to try it now. Will attempt in the AM. I think I might have misunderstood a step in the directions ...
 

·
Super Moderator 2010 SLK300 2LOOK
Joined
·
14,765 Posts
Yep. The top went up and down just prior to the install. It's not the top. It's the smarttop, somehow.
Does the green indicator light on the smarttop controller flash when you press the unlock button once on the key fob? If it does not, then it's wired incorrectly. It could be as simple as one of the wire splicers not making a good connection.

If you disconnected the smarttop controller to go back to the OEM way did you reconnect wires 74 and 56 because they were actually cut and your roof would not work anyway.

Hope this helps.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #15
Aurgh. (Hanging head in shame). Dyslexia is a thing terrible.

Two wires need to be cut and controller wires attached to each end. I had both attachments exactly opposite. Guess I backwards read the instructions.

Works great now, although the key sequence is a tad different from the instructions. (Four clicks to lower the roof and keep the windows down).

I'm going to enjoy this. Now to keep the wife from accidentally flicking the controller button. :)

Thanks for the assist everyone.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
Glad u got it sorted. it really is a straight forward install. go have a beer!
 

·
Registered
Joined
·
96 Posts
Glad you got it working. Had mine installed for a week now and love it! I too find that 4 clicks work better as sometimes I have to try twice to get the roof to lower when doing the 3 click routine. Probably just a matter of getting the timing down on the remote. Enjoy!
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
I know mk, she means play with it!
 
1 - 20 of 29 Posts
Status
Not open for further replies.
Top