Mercedes SLK World banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi

Have got a really annoying issue in that when I brake at low speed I can hear this clicking/ticking sound. It sounds like there is a stone stuck in the tyre, but there isn't one and it only comes on when you brake!

Had the pads changed about 4 months ago, but don't know if it is since this as only really noticed since I've been having to hood down quite a bit and cannot remember if it was happening before.

Had a chat with the local garage who fitted the pads and they don't seem too concerned, I however am paranoid that I am going to damage the discs £££££

Anybody else experienced this??
 

·
aka John
Joined
·
13,012 Posts
Hmmm - neither of mine make that sort of noise, and I think - like you - I'd rather be safe than sorry.

I'd do a careful visual inspection of the disks and pads as a starting point.
 

·
Premium Member 2006 SLK350
Joined
·
6,796 Posts
If you have the time and patience...raise the right front and rotate it slowly and listen. while you have it up, turn the wheel out (eg hard left) and inspect the tread.

IF YOU'RE USING THE CAR'S JACK DROP THE CAR DOWN, TURN THE WHEEL OUT THEN RAISE IT AGAIN. FAILURE TO DO SO WILL PROBABLY RESULT IN THE CAR FALLING OFF THE JACK AS YOU TURN THE WHEEL.

repeat on the other side.

MAKE SURE YOU CHOCK THE REAR WHEELS.
 

·
Premium Member
Joined
·
2,454 Posts
Hi

Have got a really annoying issue in that when I brake at low speed I can hear this clicking/ticking sound. It sounds like there is a stone stuck in the tyre, but there isn't one and it only comes on when you brake!

Had the pads changed about 4 months ago, but don't know if it is since this as only really noticed since I've been having to hood down quite a bit and cannot remember if it was happening before.

Had a chat with the local garage who fitted the pads and they don't seem too concerned, I however am paranoid that I am going to damage the discs £££££

Anybody else experienced this??
Just looked through my service records... Not sure if it was the same problem as yours. There was some kind of noise in the front-maybe it was the front right, I'm not sure. Dealership found that it came from front right and left brake pad holders scraping the rotors. They replaced the holders under warranty (spring part# 000-421-96-91). I have a 2005 SLK350 and this was done back in 09/04/07 when it had 28,095 miles.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top