Mercedes SLK World banner

1 - 9 of 9 Posts

·
Registered 2005 SLK350
Joined
·
9 Posts
Discussion Starter #1 (Edited by Moderator)
Hi folks - yes I know there are loads of threads on this and ive spent hours searching for an answer and just when I think ive found it I havent !
I have UK SLK R171 2005 350 Brabus with standard 'non' comand radio head unit. I have purchased an Erisin ES8740S unit which is apparently designed for the car ! Installed unit and all powers up but guess what - no FM reception ! From the searches ive worked out that the ant amp isnt getting power but I cant figure out the fix !
The antenna out wire from the new unit has the coax connector and a blue wire thats 5v with ignition off and 12v with ignition on.
Ive checked out thread Radio reception question but my OEM plug has no wire going to pin 13 so thats not the answer.
So my question is what do I connect that blue wire to please.
 

·
Registered 2005 SLK350
Joined
·
9 Posts
Discussion Starter #2
So ive now installed a Fakra power injector and fed it with switched 12v +ve and ive checked and core of the fakra plug/antenna cable has 12v +ve but the reception is still non existent ! I take the new unit out and plug my old MF2420 in and radio reception is great. What am I missing guys - there must be another feed from the original radio loom ?
 

·
Premium Member 2008 SLK350
Joined
·
2,676 Posts
So ive now installed a Fakra power injector and fed it with switched 12v +ve and ive checked and core of the fakra plug/antenna cable has 12v +ve but the reception is still non existent ! I take the new unit out and plug my old MF2420 in and radio reception is great. What am I missing guys - there must be another feed from the original radio loom ?
Probably because you are using the wrong pin. To power on the antenna amp you should use pin 3 of connector 3 as shown in this picture.
Don't be mislead where it says "Connector 2"in the white area. Connector 2 is reserved and it should have read Connector 3. In the original wire loom there should be a blue/white wire there.
Should be connected to pin 1 on antenna amp.
See also attachment.

584943
 

Attachments

·
Registered 2005 SLK350
Joined
·
9 Posts
Discussion Starter #4
Thanks Pete - sorry but I am being thick ! When you say pin 3 of connector three should be connected to pin 1 on antenna amp where do I find pin 1 of the antenna amp - is that the blue cable thats on the fakra adapter ?
 

·
Premium Member 2008 SLK350
Joined
·
2,676 Posts
Pin 1 of the antenna amp you will find at the antenna amp in the trunk. :)
But there should run a blue/white wire from there to pin 3 of connector 3 in the original OEM wire loom. That is the one you should connect to a wire that carries 12V when the ignition or radio is switched on. So possibly the blue wire you mention in the loom that came with the new radio.
 

·
Registered 2005 SLK350
Joined
·
9 Posts
Discussion Starter #7
Conclusion - all now working with some help from Sneaky Pete - thankyou. As Pete said the blue & white wire in existing loom needs 12v switched supply (which it wasn't getting from the Erisin HU - despite Erisin saying it should). This alone didnt fix the problem though as I added this supply but still no radio !! I then discovered the Erisin Fakra adapter somehow extracts and injects 12v +ve through the central core of the coax. I swapped out the Erisin connector for an old fashioned fakra adapter where you connect ext 12v supply to a blue wire to inject power (and didnt connect the 12v supply wire) and hey presto no 12v +ve in core and radio works perfectly.

So I now have a unit that looks factory, brings the car tech upto 2020 standards with Apple Play, Google nav, HDD jukebox, touch screen, OBD etc and all for £220. Sound quality is pretty good (as good as the stock unit) - for the money I am very pleased.
 

·
Premium Member 2008 SLK350
Joined
·
2,676 Posts
And to make it more complicated, if you had a FL R171 then you would have needed the Erisin Fakra adapter. In the FL R171 the antenna amp receives it's power through the coax..... :rolleyes:
MB probably wanted to save some money by deleting 1 (one) wire.......
 

·
Registered 2008 SLK200
Joined
·
20 Posts
And to make it more complicated, if you had a FL R171 then you would have needed the Erisin Fakra adapter. In the FL R171 the antenna amp receives it's power through the coax..... :rolleyes:
MB probably wanted to save some money by deleting 1 (one) wire.......
Yes, there I am again. I just read that I need that adaptor. Where can I order it?
Conclusion - all now working with some help from Sneaky Pete - thankyou. As Pete said the blue & white wire in existing loom needs 12v switched supply (which it wasn't getting from the Erisin HU - despite Erisin saying it should). This alone didnt fix the problem though as I added this supply but still no radio !! I then discovered the Erisin Fakra adapter somehow extracts and injects 12v +ve through the central core of the coax. I swapped out the Erisin connector for an old fashioned fakra adapter where you connect ext 12v supply to a blue wire to inject power (and didnt connect the 12v supply wire) and hey presto no 12v +ve in core and radio works perfectly.

So I now have a unit that looks factory, brings the car tech upto 2020 standards with Apple Play, Google nav, HDD jukebox, touch screen, OBD etc and all for £220. Sound quality is pretty good (as good as the stock unit) - for the money I am very pleased.
I guess that Erisin adapter you have is the one I need.
I have a Facelift SLK from 2008 and have exactly the same problem.
Is there anyway that you would sell it to me (problem is I am in Holland......) ?
 
1 - 9 of 9 Posts
Top