Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 20 of 31 Posts

·
*Registered
2006 SLK55 AMG
Joined
·
134 Posts
Discussion Starter · #1 ·
I just purchased my 06 SLK55 AMG about a month ago and it has a high pitch whine coming from the steering pump/pulley area. I assumed it was the steering pump and replace it with a LUK pump. It still sounds the same. I wonder if it is another pulley, maybe the tensioner?

I could use some direction if anyone else has had experience with this. Again, it is definitely from that area in the drivers side front pulley area.

Thanks for any input.
 

·
Founding Member 2006
Joined
·
108,893 Posts

·
Founding Member 2006
Joined
·
108,893 Posts

·
Founding Member 2006
Joined
·
108,893 Posts
see my post above yours for other search hits
 

·
Founding Member 2006
Joined
·
108,893 Posts

·
*Registered
2006 SLK55 AMG
Joined
·
134 Posts
Discussion Starter · #11 ·
Did your belt whine? Like a bad steering pump? I would think that would be more of a squeel. Let me know. I just ordered a new idler and tension pulley. I figure if I'm going to the trouble I might as well. I could do the belt also as they're cheap. I bought it with 93k miles and I don't know if any of the 3 have been replaced.

Sent from my SM-G920P using Tapatalk


REVISED: Ordered the belt too. I'm a bit picky about maintenance so I don't mind the added 40 bucks.
 

·
Registered
Joined
·
146 Posts
I get a whine usually after I've been driving for a while then stop for a few minutes , the whine comes in after restarting then slowly goes away. You would swear it was a power steering pump but it's not that. I've had the car over 12 months and it has always done it. There are a few theads on MB World about it , seems to be the nature of the beast.
 

·
*Registered
2006 SLK55 AMG
Joined
·
134 Posts
Discussion Starter · #14 · (Edited)
Still whining

Here is a short clip of the sound. [ame]https://vimeo.com/147811097[/ame]

I've installed a new steering pump, idler pulley, tension pulley and serpentine belt. The whine is still there. It whines louder at start up but continues constantly.
 

·
Registered
Joined
·
146 Posts
I've looked into this before and it's more than likely the oil pump.
From what I've read it's nothing to worry about. Mine has always done it after I stop for a few minutes then start again.
 

·
*DAS/STAR Premium Member
2005 SLK55 AMG
Joined
·
4,038 Posts
I think most do it

I had mine checked out when I bought it, figuring the belt may need replacing and the Indy said 'thats how they sound'

Mine's not loud, but you can hear it if you listen for it on tickover ..
 

·
*Registered
2005 SLK55 AMG
Joined
·
1,893 Posts
Here is a short clip of the sound. https://vimeo.com/147811097

I've installed a new steering pump, idler pulley, tension pulley and serpentine belt. The whine is still there. It whines louder at start up but continues constantly.
Sounds more like alternator bearing whine to me, but not easy via vid clip. Stethoscope time I think!
 

·
*Premium Member
2005 SLK55 AMG /2005 SLK350
Joined
·
6,174 Posts
Try starting it with the belt removed and see if it goes away? I presume you checked the PS fluid level... Mine was low due to a bad seal on the cap, it took a while but eventually it lost enough fluid to start making noise. My noise was sensitive to steering though- it was loudest during low speed cornering.
 

·
*Registered
2006 SLK55 AMG
Joined
·
134 Posts
Discussion Starter · #19 ·
Try starting it with the belt removed and see if it goes away? I presume you checked the PS fluid level... Mine was low due to a bad seal on the cap, it took a while but eventually it lost enough fluid to start making noise. My noise was sensitive to steering though- it was loudest during low speed cornering.
Yes, i actually just replaced the steering pump and the reservoir is full.

Sent from my SM-G920P using Tapatalk
 
1 - 20 of 31 Posts
Status
Not open for further replies.
Top