Mercedes SLK World banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
166 Posts
Discussion Starter #1
Hello All
My problem is somewhat baffling!
When i drive my 1998 SLK230K and stand on the accelerator pedal somewhat firmly, when the engine revs are at about 4500 the engine will develope a stutter or miss (sometimes i can feel the same miss when driving normally around town but very rarely and usually when the ambient tempreature is around the 35-45 degrees C.). Other wise, under gentle acceleration and normal driving it performs fine.
Yesterday when i went for a theraputic drive to dee stress after a somewhat exasperating day after about 3km of normal town driving under 60k/h I put my foot down to accelerate from about 10k/h the engine started to miss badly. I drove back to my house (no MB stealership for 180k) parked in the garage of the house (still missing badly) turned the engine off. Immidiatley went for a restart and it ran without the miss.

I had thought that i need to replace the coils when I next go to my spare parts guy as that may be the problem? Now i am unsure if it may not be infact the fuel filter clogged up. I will probablyt change both.

I have looked on the 170 forum for the location of the fuel filter and associated type of details with no luck so far.
One tread mentioned it is in the Boot/Trunk. I looked at the Crossfire service manual and it locates it under the vehicle, can any one shed some light on this for me please. :(
 

·
Administrator - Founding Member since 2006
Joined
·
94,100 Posts
Moving this to the r170 general discussion from Australia section as this topic is not restricted to just 'down under'
 
1 - 3 of 3 Posts
Top