Mercedes SLK World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Ok need advice! Got a check engine for codes PO136 and P0400. Put a new ERG valve sensor on. Then got codes PO170 and PO173. cleaned air flow sensor but noticed the round plastic clamp had some of it to break off could this be the problem? Engine lights drive me nuts! Any advice? Please!!
Oh it's a 2001 SLK320
 

·
Administrator 2009 SLK 55 AMG/Founding member 2006
Joined
·
94,921 Posts
:D

we know what it is

it is in your profile to the left:

Vehicle: 2001 SLK320
 

·
Super Moderator CA 2012 SLK55 AMG w/P30
Joined
·
12,451 Posts
0170 and 0173
For this guy, it seemed to be a loose hose on his clk


At least till the people who actually know something show up :wink: you can watch a clip ✔
 

·
Registered 2002 SLK320
Joined
·
2,011 Posts
Hi,

That sort of code can have many meanings, it is basically telling you that Fuel Adaptives are at one end of their scale and the Fuelling is still incorrect :wink:

My first port of call would be checking for Air Leaks, and also restrictions to Air Intake, such as a choked filter etc.

HTH, Cheers Dave
 

·
Premium Member 2004 SLK350
Joined
·
4,419 Posts
Cleaning the MAF is ok's but that not necessary means that maf is ok. In das you can check the actual values and recommended values for your maf.

Again in DAS i can't find p0170/p0173 for your me2.8 ecu so your tool can't pull the right code.
In das I found p0171/p0172 and both point to a bad maf and performing a self-adaptation test, also is mention the intake manifold sensor.
 
1 - 6 of 6 Posts
Top