Mercedes SLK World banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I am in need of some help. I recently had an ECU that I got off of ebay for 80 bucks unlocked by Beckmann Technologies in North Carolina due to my ECU being bad. I then took it to a Mercedes dealer and had it reprogrammed, and now my car runs again. Yay! Since the reprogram, I have driven about 120 miles.


I want to explain the whole situation so that all the variables can be accounted for. When I removed the ECU I bent a pin in the ASR module and now I have and ASR/BAS light on. (I think this is completely unrelated to the engine issues, but I don't know.)


When I turn the car on, the fan runs on high all the time. When driving the car, it will accelerate regularly if the throttle is held below 1/4 position. Anymore and it surges violently, like the whole engine is cutting out intermittently. If I keep it at 1/4 though while driving and allow the rpms to slowly rise, they will, but then the car will not allow rpms over approximately 4300 when it starts violently cutting out again. Out of gear (I have a 5spd) regardless of throttle position, I can rev the engine up smoothly and quickly, but it is still limited to 4300 rpms.


Before the ECU was fixed, the car sat for over a month. I have pulled the K40 relay before and I could tell it had been repaired before. So, I have ordered an ASR module, a K40 relay, and a new MAF sensor in order to attempt to remedy this. I have also tried the ECU soft rest procedures, but it still has problems. Also, as I drive it more, it surges ever so slightly less as it revs up while driving, but still anything over 1/4 throttle , or at 4300 rpms the car starts surging violently.


I'm kind of thinking that it is in some sort of fail safe mode (if that exists) which is why the fan blows high and the rpms and fuel flow are all very limited.


If you can help diagnose this and it works, I will send you beer money via paypal. THANKS!
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,061 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #4
Didn't know the ESP was a thing. Apparently neither did the Mercedes dealer that did the work. Also, no codes or engine light, I checked that right away.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,061 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Well I tried the esp sync thing, the ASR light didn't go out, but I'm thinking its the pin I bent and then "repaired" so ill swap the module. As for the fan, I'm thinking / hoping probably k40.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #7
I replaced the battery, k40, brake light switch and maf. Car is running much better. Asr / BAS light remains on, and now it has smooth power, but cuts out at about 4300 rpms though. I suspect it it power limiting due to the asr/bas light. I took it and got the asr codes read, and it said it had a brake light switch code, but the code was cleared by the guy. No idea what to do next.
 

·
Registered
Joined
·
43 Posts
I am in need of some help. I recently had an ECU that I got off of ebay for 80 bucks unlocked by Beckmann Technologies in North Carolina due to my ECU being bad. I then took it to a Mercedes dealer and had it reprogrammed, and now my car runs again. Yay! Since the reprogram, I have driven about 120 miles.


I want to explain the whole situation so that all the variables can be accounted for. When I removed the ECU I bent a pin in the ASR module and now I have and ASR/BAS light on. (I think this is completely unrelated to the engine issues, but I don't know.)


When I turn the car on, the fan runs on high all the time. When driving the car, it will accelerate regularly if the throttle is held below 1/4 position. Anymore and it surges violently, like the whole engine is cutting out intermittently. If I keep it at 1/4 though while driving and allow the rpms to slowly rise, they will, but then the car will not allow rpms over approximately 4300 when it starts violently cutting out again. Out of gear (I have a 5spd) regardless of throttle position, I can rev the engine up smoothly and quickly, but it is still limited to 4300 rpms.


Before the ECU was fixed, the car sat for over a month. I have pulled the K40 relay before and I could tell it had been repaired before. So, I have ordered an ASR module, a K40 relay, and a new MAF sensor in order to attempt to remedy this. I have also tried the ECU soft rest procedures, but it still has problems. Also, as I drive it more, it surges ever so slightly less as it revs up while driving, but still anything over 1/4 throttle , or at 4300 rpms the car starts surging violently.


I'm kind of thinking that it is in some sort of fail safe mode (if that exists) which is why the fan blows high and the rpms and fuel flow are all very limited.


If you can help diagnose this and it works, I will send you beer money via paypal. THANKS!
Did u check abs control unit connection? I had the same issues..nearly the same diagnostics..just clean them connection and hopefully will do

Trimis de pe al meu SM-G900F folosind Tapatalk
 

·
Registered
Joined
·
43 Posts
I replaced the battery, k40, brake light switch and maf. Car is running much better. Asr / BAS light remains on, and now it has smooth power, but cuts out at about 4300 rpms though. I suspect it it power limiting due to the asr/bas light. I took it and got the asr codes read, and it said it had a brake light switch code, but the code was cleared by the guy. No idea what to do next.
Abs sensor needs a different diagnostic to be reseted

Trimis de pe al meu SM-G900F folosind Tapatalk
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top