Mercedes SLK World banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
:crying:After recently replacing the front brake rotors and pads, a transmission oil change and 2 new front tyres (NZD $2000), my car decided that I had not spent enough on it.


The ABS / ESP lights came up but my garage who did the above work didn't comment on them, simply reset the codes. About a week later my car went into limp mode, both ABS / ESP and the Check Engine Light came up and you couldn't shift out of first gear.


Turning the car off and waiting did not work. So into a Mercedes dealer on a truck it went. Initially they diagnosed the Yaw Sensor, (NZD $1900 to fix) but when the same model car was traded in they swappped parts and it made no difference. Sadly the ECU needs to be replaced (NZD $7400 including the diagnostics done to date) it had to be programmed in Germany and is specific to the VIN of your vehicle, so I have been told.


Given that my car is now 15 years old the service agent told me we could repair the ECU and then face transmission problems or other issues. We took the weekend to look at options, you can't sell a car in limp mode, and given that we had spent about $4k on it this year alone we are obliged to fix it. As I told the service agent, it is "heart not a head" decision, we both love the car and will roll the dice that other things don't fail immediately.


Just thought I woiuld let others know the symptoms and share the pain
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top