Mercedes SLK World banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Replaced my K40 and have a new PSE pump.
Dome lights work properly when switched on manually and when I unlock or lock with key fob.
Dome light auto-dims correctly.

Dome light does not come on when either door is opened .
Trunk light does not come on when trunk is opened.
I doubt both door and trunk switches are bad.

Any ideas?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,067 Posts
did they work before?
check fuses?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
did they work before?
check fuses?
As long as I've had the car there where issues with the door locks and lights.
That's why I replaced the PSE.
Now the key fob operates lights and locks as it should.

Checked all fuses and, as I said, the key fob unlock function operates interior dome and trunk as it should.
Manually clicking the switch on dome to "on" operates dome as it should.

Still though, neither door or trunk being "open" turns on dome or trunk light.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,067 Posts

·
Premium Member 2004 SLK200K
Joined
·
10,761 Posts
Is the PSE the correct one for your VIN ?

If you've replaced with the same model you had before, maybe a previous owner had used one that wasn't right one, hence always having problems...?
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,126 Posts
Is your roof operating normally?

For the trunk light, there should always be +12V on one side of the bulb - can you confirm it's there? That should narrow down the culprit.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top