Mercedes SLK World banner

Status
Not open for further replies.
1 - 20 of 80 Posts

·
Registered
Joined
·
600 Posts
I did it with recently with some instruction for another model and it works, this instructions wuold've saved me some headaches. Sometimes the voltage screen takes time to come up, but with patience it can be done.
 

·
Registered
Joined
·
11 Posts
"Thanks"!

A huge "thank you" for sharing the detail on resetting the oil service indicator on my auto! One of these days I'll become familiar with MB's stash of all these goodies and won't have to trouble folks like you for help. Meanwhile....your excellent assistance made my day!!

Have a great fall season!

Alan

:tu:
 

·
Premium Member
Joined
·
1,314 Posts
Is this information no longer in the owners manual? It certainly used to be.

Len
 

·
Registered
Joined
·
270 Posts
I tried it on mine and "Service not confirmed" Message showed up..

The indicator shows Service C now though... so I guess it did reset in someway..?

Any thoughts?
 

·
Administrator - Founding Member since 2006
Joined
·
93,497 Posts
eddean50,

Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!


You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.




If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.
If you wish to PM (Private Message) someone, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.

Thank you,
Jeff
Founding Member #12/Moderator
 

·
Registered
Joined
·
36 Posts
Thank you for this valuable info John. I recently changed the oil and filters in my 2006 SLK-280 as the multifunction display indicated that I was over 800 miles beyond service E. I tried to reset the diplay and now it tells me that it's over 1400 miles over service D. Tomorrow I will try what I have just learned from your information and see what happens. Recently the multifunction display shows what appears to be a pink shrimp and it seems to grow every day. I hope my display is not taking a turn for the worse. Hopefully, once I reset the service display it will solve the problem. I'll keep you posted.
 

·
Banned
Joined
·
87 Posts
The Trick!

I did it with recently with some instruction for another model and it works, this instructions wuold've saved me some headaches. Sometimes the voltage screen takes time to come up, but with patience it can be done.

The trick is to press the reset indicator VERY rapidly three times in succession!

Unfortunately, the instructions don't competely work for my 2010. I wanted days, and I've got miles (10K). :usa:
 

·
Sadly Woolly has passed away
Joined
·
17,375 Posts
. . . Recently the multifunction display shows what appears to be a pink shrimp and it seems to grow every day. I hope my display is not taking a turn for the worse. Hopefully, once I reset the service display it will solve the problem. I'll keep you posted.
Unfortunately there's been a few posts here about the appearance of 'pink shrimps' (bad pixels) in the MFD - mostly from owners living in hot climates. No easy fix except for changing the instrument console.




 

·
Sadly Woolly has passed away
Joined
·
17,375 Posts
. . . Unfortunately, the instructions don't competely work for my 2010. I wanted days, and I've got miles (10K). :usa:
As the service indicator is based on miles OR days (10-13K miles OR 12months ), it will show 'miles to service' until you're getting close to days remaining, then change to days, depending upon which looks like is going to occur first.




 

·
aka John
Joined
·
13,012 Posts
The trick is to press the reset indicator VERY rapidly three times in succession!

Unfortunately, the instructions don't competely work for my 2010. I wanted days, and I've got miles (10K). :usa:

Hey Sally - on the MFD, you are a bit limited in what you can set - it's basically a "reset" sorta thing - so you now should be at 10k miles and 365 days.




 

·
Banned
Joined
·
87 Posts
Hey Sally - on the MFD, you are a bit limited in what you can set - it's basically a "reset" sorta thing - so you now should be at 10k miles and 365 days.
Yes when I first got the car, it was counting down the days (from 365).

When we changed the oil and filter, we reset the MFD (Multi-Function Display?) and it displayed 10K miles rather than days. We figured we had better leave well enough alone. Next year we'll try again.

BTW, here the owner's manual says to change the oil & filter every year or 10K miles whichever come first. Also we only have A & B services. European cars must be different with longer service intervals and other service notations?
 
1 - 20 of 80 Posts
Status
Not open for further replies.
Top