Mercedes SLK World banner

1 - 7 of 7 Posts

·
Registered 2000 SLK230
Joined
·
4 Posts
Discussion Starter #1
Hello, i am having a time trying to get the hvac controls on my 2000 slk230 working. i bought the car as a project and had to switch the ecm and immobilizer just to get it to run. i was wondering if this hvac controls have to be programmed to the ecm . i have did all the usual maintenance on the heater blower motor, such as take apart ,clean,lubricate and replaced resistor. when i had it out i ran voltage from battery direct and it works. i am getting power on middle pin, but the fan speed button does nothing and the flapper setting dont work either. thanks in advance for any help.
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,606 Posts
No Version Coding to do with Theft Relevant Parts, sounds like your HVAC Controller is FUBAR, the Flaps are controlled manually by the White Fingers on the Rear, which often become misplaced when someone has had it out and then of course the Flaps don't work ...................

However, Blower and A/C and Temperature are all Electronic Functions ;)
Good Used ones are not usually horrendously priced ;)

HTH,
 

·
Registered 2000 SLK230
Joined
·
4 Posts
Discussion Starter #4
No Version Coding to do with Theft Relevant Parts, sounds like your HVAC Controller is FUBAR, the Flaps are controlled manually by the White Fingers on the Rear, which often become misplaced when someone has had it out and then of course the Flaps don't work ...................

However, Blower and A/C and Temperature are all Electronic Functions ;)
Good Used ones are not usually horrendously priced ;)

HTH,
thanks dave for responding so quick, i should have added more info. the original control only worked by pushing the record button ,then the fan would come on on low speed i think. both amber lights are lit with key on position. i pulled another control from my local junkyard and it will do nothing but both amber lights are lit. the third unit i got does the same. is it just bad luck to get 2 units that dont work or maybe i have wiring issue.
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,606 Posts
TBH this would be a whole lot easier by first running an HVAC full diagnostic on SDS, anything else is just pure guesswork, and that just results in un-necessary expense, excessive vehicle down time and spending money on parts you don't need.

It isn't wort trying to diagnose it on any other Machine, they will "lead you up the garden path" because they do not see everything ;)

HTH,
 

·
Premium Member 2001 SLK200K/2001 SLK320
Joined
·
1,790 Posts
i pulled another control from my local junkyard and it will do nothing but both amber lights are lit. the third unit i got does the same. is it just bad luck to get 2 units that dont work or maybe i have wiring issue.

I find it hard to believe that you have now got not one but three defective units, therefore I think I'd start by looking towards the fuses, paying close attention to any that are "Tempmatic" associated, although you could probably ignore F1f15 for now ..
 

Attachments

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,606 Posts
I find it hard to believe that you have now got not one but three defective units, therefore I think I'd start by looking towards the fuses, paying close attention to any that are "Tempmatic" associated,
I will +1 second that ;)
 
1 - 7 of 7 Posts
Top