Mercedes SLK World banner

Status
Not open for further replies.
1 - 18 of 18 Posts

·
Registered 2002 SLK 230 R170
Joined
·
355 Posts
Discussion Starter #1
Went out for a drive in my SLK yesterday for the first time in 2 weeks. :grin:

Discovered that the Cruise Control was not working :frown: although the orange light on the stalk comes on when pushed in.

Checked - -
Tyre Pressures - ok
Fuses (2) [ Under Hood & Side of Dashboard ] ok
No fault lights on instrument panel
No codes thrown when checked with my Magic box.
Brake Lights working normally

Can anyone think of anything else easy to check or am I off for a visit to my Indy .

Mike
 

·
Registered
Joined
·
29 Posts
Check if the roof works.(.lets see...bonnet in the front...boot in the back...drop head??? above?). Like the cruise control, the top function needs to know the wheel speed. This will help rule in/out sped sensors and reluctor rings.
 

·
Registered
Joined
·
3 Posts
Please check battery voltage with engine off for at least 2 hours. I've seen low voltage cause CD to stop working with battery voltage below 12.1 volts. Even with engine running and alt output close to 14.2, CC measures only battery output voltage. You need 12.6-13.2 on egg me off voltage.
 

·
Premium Member 2008 SLK200
Joined
·
385 Posts
Hi
Good day.

I had this problem before.

And the cause of it was the steering angle sensor malfunction.
There was no repair but to change the angle sensor.
When the angle sensor malfunction, the ESP also doesn't work.

I costed me about USD 400.00

Thank you & have a nice day
 

·
Registered 2002 SLK 230 R170
Joined
·
355 Posts
Discussion Starter #7
Thanks to all who gave suggestions -

Check if the roof works - I had the roof down when I found the problem. Just checked it again - Works OK

Check battery voltage - I Just fitted (3 weeks ago ) a New Varta AGM battery. Just in case I put a DMM across the terminals. Result - 12.4v. Then I remembered to take a terminal off (Open Circuit Test) - Result 12.9v

Steering angle sensor malfunction - This should give me an EPS fault light + code. Neither present.

Have just rung the Indy & have an appointment on Thursday.

Will let you know the Cause & Cure then.

Mike
 

·
Premium Member 2004 SLK200K
Joined
·
10,745 Posts
Wasn't pressing the stalk in for the speed limiter, not the cruise control, or was the orange light comment just to say there was life there?

When was it last working? Have you changed tyres since then?
 

·
Registered 1999 SLK230
Joined
·
204 Posts
I use cruse on my 99 230 all the time, if you push the stalk in it turns on speed limiting, and turns the light on and cruse off

If your is the same as mine you dont need to turn it on like a lot of vehicles, it is on by default.
If the light is on press the stalk in again to go back from speed limit to cruse, and the light should go off.

Then once at the speed you what just lift up the stalk and you are done, to manualy disingage pess stalk backwards (towards front of car )

Hope that makes sence, but as i said not sure your's is the same but that is how the 99 version works.

By the way i have found a nice feature in the slk cruse control is that it will drop down a gear when going down a hill to stop you going overspeed, how that is a nice touch

Cheers from down under
 

·
Premium Member
Joined
·
342 Posts
Hi Ixion,
I'll second what PaPaBear said:

Pull towards: Activate at a previously set speed
Push up: set speed or increase current speed in 1mph increments
push down: decrease speed in 1mph increments
push away: turn off
push stalk in: set speed limiter

https://www.manualslib.com/manual/102194/Mercedes-Benz-Slk-230.html?page=137#manual

I'm pretty sure the 320 would be the same as the 230, I can't see why they'd make it any different?

Cheers

Dez >:D
 

·
Registered 2002 SLK 230 R170
Joined
·
355 Posts
Discussion Starter #11
Hi,

Getting back to you about my problem.

Car delivered back with Cruise Control still not working.

The Indy found no Codes with his Star - DAS unit.

After discussion we decided to replace the Switch Unit on the Steering Column. Has to come from Germany (5 days) so fitting end of next week.

If that does not work ???.


Does anyone know if a Problem in the Front SAM could cause this problem ??

Mike
 

·
Registered
Joined
·
29 Posts
My cruise control failed while at highway speed. It just fell out of cruise.

Cause: A toothed sensor ring on the left rear axle cv shaft had failed. A section of the ring fell out. Even though the other three wheels were sending speed data, it was enough to kill the cruise control.

While you are waiting for the switch, pull the rear wheels. A speed ring is located on the wheel end of each CV axle. You can see it just enough to inspect it as you turn the axle.

The rings are pressed on, and develop rust underneath, cracking the ring. New rings are not available in the US. Get one or two from a UK ebay source. Around $14 US. They can be tapped in place with a light hammer.
 

·
Registered 2002 SLK 230 R170
Joined
·
355 Posts
Discussion Starter #13
UPDATE on Cruise Control Problem

My Cruise Control Saga Continues - :crying:

SO FAR - My Indy Mechanic has

1/Checked all the fuses and and Relevant Wiring.

2/ Replaced the Cruise Control Switch Assy.

3/ Changed the K40 for a new one (He happened to have one waiting to co on another SLK) He Then put mine back on the my Car.

4/I am now waiting for Control Module Combo Relay No - 170 545 02 05 (170 545 02 32) Which i've bought second hand and will arrive Wednesday

Indy has said "Very unusual to have Cruise Control Fail & no Fault Codes Seen" :surprise:

I am not going to let this beat me. But I dread to think of the Hours racked up so far.

Anyone else had a Flash of inspiration about my Problem ??

Regards

Mike



 

·
Registered 2002 SLK 230 R170
Joined
·
355 Posts
Discussion Starter #14
My cruise control failure

Re MY CRUISE CONTROL FAILURE :crying:

Does anyone with a STAR System know what you can CODE with it in respect of the CRUISE CONTROL

My Chassis No is - WDB1704492F217411

I am still trying to sort this problem and already have spent half a fortune on Labour Costs.

Mike
 

·
Registered 2002 SLK 230 R170
Joined
·
355 Posts
Discussion Starter #15
Cruise Control finally working again.

Fourth visit to Indy who found it was the wire in the main Fuse Box (Fuse 10) was not making a connection.

Not something normally expected.
 

·
Registered 2009 SLK200 2Look
Joined
·
298 Posts
I have cruise control but only checked it the once - it works. I have voice control - that also works. My GPS Navigation also works. My steering wheel buttons work also - All Work! My problem is finding a place to go for the nav, operating the cruise control and voice control for the CD shuttle. And finding some one to phone via my hands free - any ideas?

Thanks - !
 

·
Registered 2009 SLK200 2Look
Joined
·
298 Posts
Hi Ixion,
I'll second what PaPaBear said:

Pull towards: Activate at a previously set speed
Push up: set speed or increase current speed in 1mph increments
push down: decrease speed in 1mph increments
push away: turn off
push stalk in: set speed limiter

https://www.manualslib.com/manual/102194/Mercedes-Benz-Slk-230.html?page=137#manual

I'm pretty sure the 320 would be the same as the 230, I can't see why they'd make it any different?

Cheers

Dez >:D
Did some one spot an elephant?
 

·
Premium Member
Joined
·
342 Posts
1 - 18 of 18 Posts
Status
Not open for further replies.
Top