Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
542 Posts
Discussion Starter #1
My CPS just recently took a dump on me, so I ordered one from OEDiscountparts.com. While trying to figure out where the devil the thing goes I finally found a picture that showed me exactly. I thought y'all might like to see this photo too, incase you have yours go out. BTW I also took a chunk of my knuckle out too whilst having my hand in the back of the engine bay. I won't show that picture :)
 

Attachments

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
Were you able to do the adaptation (with SDS) after replacing the Crankshaft Position Sensor?

IIRC, it may be easier if you are able to remove the hot film MAF assembly (as shown missing in the photo) and cutting the plastic tie that holds the wire leading to the CPS.

Just had mine replaced last week.
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
My CPS just recently took a dump on me, so I ordered one from OEDiscountparts.com. While trying to figure out where the devil the thing goes I finally found a picture that showed me exactly. I thought y'all might like to see this photo too, incase you have yours go out. BTW I also took a chunk of my knuckle out too whilst having my hand in the back of the engine bay. I won't show that picture :)
Not quite sure about the photo. Is this the back of an M272 engine? I do not recall the two black round plugs at the left bank of the M113 engine.
 

·
Registered
Joined
·
542 Posts
Discussion Starter #5
Were you able to do the adaptation (with SDS) after replacing the Crankshaft Position Sensor?

IIRC, it may be easier if you are able to remove the hot film MAF assembly (as shown missing in the photo) and cutting the plastic tie that holds the wire leading to the CPS.

Just had mine replaced last week.
I removed the MAF, but it wasn't necessary. I slid the sheath that covers the connection up cable. I think that's what you're asking me about.

I saw that video but it left me more confused because it doesn't show anything.
 

·
Registered
Joined
·
188 Posts
CPS failures...Twice! I've owned two 2006 SLK AMGs. Both around 70k miles. Both had CPS failures. Is there a Service Bulletin on these? Is this a known issue, that should be highlighed to replace on an appropriate check? I'm very displeased to be left stranded suddenly in the middle of the road!! Extremely unsafe. Shelled out over $500 bucks each with towing and shop fees.
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts
What are the symtoms and error code when this occurs. Just curious for future reference.

Thanks
From my experience:

Initially,the engine stalled without warning. I pulled off to the side, turned off ignition, waited a few minutes and restarted the vehicle. Engine restarted and car ran fine except CEL warning light showed up. It was late in the evening, so I just turned off the engine after parking in home garage. Next morning, the engine started fine and CEL warning light disappeared. Talked to MB service advisor and he recommended observation as the CEL light went away.

A week later, while getting on the the off-ramp from freeway, engine stalled with our warning. I was able to cruise and get into the "emergency" lane at the side of the off-ramp. This time turning off the ignition and restarting did nothing. Engine would crank and nothing else would happen. Had to MB roadside assistance and they sent flat bed tow truck and got it into MB shop in mid-evening.

Next morning, service advisor said the Crankshaft Position Sensor was "toast", i.e., non-functional.

Vehicle had 64,187 miles, and one month shy of 6 years of ownership from new, single driver.

From the Invoice: "Engine test with DAS, code P2034-008. Test individual components per Diagnostic Trouble Code (DTC), crankshaft position sensor failed resistance test (56 MegaOhms MΩ when heat is applied). Replaced crankshaft position sensor, reset rotor adaptation and test drove car."

Currently the 2008 SLK55 has 87,610 miles, and 8.5 years of ownership from new, single driver, used almost daily.
 

·
Founding Member #2 2008 SLK55 AMG
Joined
·
19,407 Posts

·
Registered
Joined
·
188 Posts
There used to be a member on this Forum named Dan, who was very savvy on our cars and associated Service Bulletins and Technical issues. Is he still on? I'm asking, "Is there a Service Bulletin on these? Is this a known issue, that should be highlighed to replace on an appropriate check?". This is an extremely unsafe issue for us owners. The symptoms described higher in this thread are exactly what I have experanced...ON BOTH SLK AMGS.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,437 Posts
There used to be a member on this Forum named Dan, who was very savvy on our cars and associated Service Bulletins and Technical issues. Is he still on? I'm asking, "Is there a Service Bulletin on these? Is this a known issue, that should be highlighed to replace on an appropriate check?". This is an extremely unsafe issue for us owners. The symptoms described higher in this thread are exactly what I have experanced...ON BOTH SLK AMGS.
Dan is no longer here. He has checked in very infrequently

http://www.slkworld.com/ask-dansslk/28374-ask-dan-section-has-been-closed-permanently.html

The Ask Dan section has been closed permanently as Dan has not returned.
We hope he is ok and will return someday.
He was last seen on Last Activity: 01-20-2015

http://www.slkworld.com/members/67-dansslk.html

Please post your questions in the appropriate section like R17,R171, or R172 general discussion section
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top