Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi all,

When I picked up my SLK I realised there was an issue in that the Comand Navigation system isn't recognising that the ignition is on and therefore steering controls, sound quality etc. arent functioning properly (I suspect these things are all connected).

Paperwork and sticky pads on dashboard would suggest that a Parrot Mki 9200 system was recently removed.

I assume that when it was removed the original unit wasnt wired back up correctly so I intend to take a look this weekend.

I have fitted stereos etc. before so soldering doesnt concern me (if required) but I wondered if anyone has a wiring diagram for the audio / power cables going to the NTG1 Command and/or HK system in case the issue is not obvious.

The system is the one with the Nav disk in the boot.

Thanks in advance for your help.
 

·
Founding Member 2006
Joined
·
108,893 Posts

·
*Premium Member
2005 SLK350
Joined
·
2,562 Posts
Hi all,

When I picked up my SLK I realised there was an issue in that the Comand Navigation system isn't recognising that the ignition is on and therefore steering controls, sound quality etc. arent functioning properly (I suspect these things are all connected).

Paperwork and sticky pads on dashboard would suggest that a Parrot Mki 9200 system was recently removed.

I assume that when it was removed the original unit wasnt wired back up correctly so I intend to take a look this weekend.

I have fitted stereos etc. before so soldering doesnt concern me (if required) but I wondered if anyone has a wiring diagram for the audio / power cables going to the NTG1 Command and/or HK system in case the issue is not obvious.

The system is the one with the Nav disk in the boot.

Thanks in advance for your help.
The Comand/HK system has an Audio Gate Way in the foot well of the passenger side of the car (search this site for more info). As part of the AGW there is the special amplifier to feed the 11 speakers. In most, if not all, audio system upgrades - when the original is the Comand/HK system, that AGW and amp are swapped out for a conventional amp system. That would be the first thing to check. Also, as part of the audio system is a fiber optic MOST ring that has to be a complete circle from the beginning back. If that ring is broken by either damage to the fiber optic or a component removed (AGW??) the system will not operate.

It may save you time to have the car hooked up to the MB Star/DAS system to see what is missing or not working.
 

·
*Premium Member
2008 SLK350
Joined
·
3,242 Posts
What mchild says.
The Comand HU doesn't has that many connections, just a connection to the optical MOST ring, power and a terminal for a wake-up signal. You could check that on the back of the unit first. Some useful info here ,the appendix contains a diagram of all connections of the HU and AGW.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Thank you for the very useful info.

I have printed the guides and will check the wake-up on the head unit today then take a look at the AGW in the footwell.

My intention eventually is to fit a Dynavin system however I would like to get everything back to factory (if possible) so I know what I am working with and that I could always put it back to factory if I sold it on.

Will keep you posted.

Thanks again
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
So...

I pulled out the Head Unit this morning and all looked fin other than (I think) a non-isolated power lead which I suspect was from the screen on the Parrot.

So then I went into the AGW and it was a it of a mess but very clear that when the Parrot was removed the speaker cables hadn't been plugged back into the AGW.

Now the HK seems to be working perfectly, radio is much clearer and HU is recognising ignition and letting me change the time etc.

The only thing that is still not working is the GPS. The Command system still thinks I am at the dealership I picked the car up from however the screen would suggest it has picked up satellites.

The audio & comms guide suggests the GPS antenna is connected to the 'Tele aid' on the RHS in the boot however after removing some carpet etc. I can't seem to find anything.

Please take a look at the attached and let me know your thoughts.

Regards,

Michael
 

Attachments

·
*Premium Member
2008 SLK350
Joined
·
3,242 Posts
The GPS antenna is connected to the NAV drive in the trunk that also contains the navigation processor. Tele-aid is a USA thing, I don't think it is present in a European spec car. But the HU shows it has picked up 10 satellites so GPS should be fine. You have to drive around a bit for a few km to let the nav processor find out what your present position is. Don't know if you already did that?
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top