Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 5 of 5 Posts

·
*Registered
2013 SLK250 CDI
Joined
·
129 Posts
Discussion Starter · #1 ·
I am using an SD card and have copied music files onto the hard disc. Everything works except twice now when I have pressed buttons on the right hand side of the steering wheel. First time it was mute to clear a traffic announcement and the second time it was phone pick-up to take a call.

The screen goes back to the media screen but instead of continuing to play the track that it was playing, it scrolls through all of the tracks on the SD card and the hard disc before announcing 'no playable files found'.

I can clear the fault by resetting the whole thing from the system menu but it's a bit tedious and I lose everything from memory (and even have to tell the car that it isn't in Germany!)

Has anyone else seen this and is there a cure? Is it possible to do a soft reset and not lose data? Turning off, waiting and turning on does not cure the problem. I have tried searching but don't really know what to put in a search engine.
 

·
Founding Member 2006
Joined
·
108,819 Posts
Try a battery reset to clear out the gremlins

disconnect neg cable for a minimum of 30 mins
reconnect cable
resynch windows and reset battery
see if issue reoccurs

oh and btw, Comand has only 1 'm'. I fixed your title
Cockpit Management and Data system - COMAND for short
 

·
*Premium Member
2012 SLK350
Joined
·
1,372 Posts
I am using an SD card and have copied music files onto the hard disc. Everything works except twice now when I have pressed buttons on the right hand side of the steering wheel. First time it was mute to clear a traffic announcement and the second time it was phone pick-up to take a call.

The screen goes back to the media screen but instead of continuing to play the track that it was playing, it scrolls through all of the tracks on the SD card and the hard disc before announcing 'no playable files found'.

I can clear the fault by resetting the whole thing from the system menu but it's a bit tedious and I lose everything from memory (and even have to tell the car that it isn't in Germany!)

Has anyone else seen this and is there a cure? Is it possible to do a soft reset and not lose data? Turning off, waiting and turning on does not cure the problem. I have tried searching but don't really know what to put in a search engine.
May be a bad SD card or one that is very fragmented.
Does everything work OK with the SD card removed?
If so try reformatting the SD card, loading it again with music files, and using it again in your car.
If the problems return try a new SD card.

Is the card greater than 32GB capacity? If so try one the is 32GB or less.
 

·
*Registered
2013 SLK250 CDI
Joined
·
129 Posts
Discussion Starter · #4 ·
I don't think it's the card because with the card removed, it scrolls through the hard disc without pausing. It does the same on a memory stick as well until I reset it.

Thanks for changing the title Jeff, I must have let spell checker correct me. I'll try the battery disconnect the next time it goes and I'm near home. (if I can find it!) When you're on a long drive, the need for music dictates a reset on the go.
 

·
*Registered
2017 SLC43
Joined
·
1,903 Posts
The car should still be under warranty. Take it to a dealer and report the issue. Hopefully there will be a software update to sort it out. Even if there isn't a fix available now for this because you have logged the problem within the warranty period, they will sort it for you free when they do develop a fix.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top