Mercedes SLK World banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Premium Member
Joined
·
123 Posts
Discussion Starter #1
I was very concerned about the state of my new to me SLK. The car shook at stop lights and the other day died on me and went into limp mode. I have motor mounts and a bunch of other parts en route from ebay but it was warm out yesterday so decided to to some digging.

The MAF sensor was disgusting! All the way up the pipe to the throttle was coated in gunk. I touched the inside of the pipe and a big gob of poo held onto my finger.

Took the whole assembly apart and cleaned it with sensor/electronics cleaner and used carb cleaner in throttle body. Let it dry and put it back together.

BAM! Bob's your uncle and it's now the bee's knee's...or the cat's pajama's if you prefer. I could do burnouts in this car if I wanted to....but I don't. All misfire codes are gone and she's stable at the stop lights.

Still will be replacing the motor/tranny mounts though. Who knows if they were ever done. Poor car. Think I'll go see the PO now and punch him in the face.
 

·
Registered
Joined
·
350 Posts
better running

also you could try turning the key to position 2.(ignition on but not starting engine) then put foot on throttle and push to floor. hold for a minute then turn key off and let off throttle pedal.
this, as i was told, resets the engine management system back to factory setting. the car learns how you drive and if the previous owner had been skulking about with low speeds and miss-fire etc it may need to be told, 'hey you have a new owner, so wakey, wakey!' R)

( can't hurt to try it. only takes a minute.)
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,266 Posts
1 - 4 of 4 Posts
Status
Not open for further replies.
Top