Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Well...its been an "interesting" first couple weeks of ownership of my '05. Yesterday, my CEL came on, and fearing that it might be something major, like the balance shaft sprocket, I immediately took it to my local mechanic to he could scan the code. What he found was something relatively minor...something having to do with the speed sensor. Anyway, he said it wouldn't preclude me from driving it until I had some time to leave it with him.

Today, I climbed in and started her up. No CEL!! What gives? Anyone ever experience this sort of thing before? Does this car get periodic malfunctions that somehow clear themselves up?

Oh...one more thing. Twice now I've gotten a notification that the left rear license plate light was out. Got out of the car to check and the light was working just fine.

Thanks in advance for your thoughts and assistance.
 

·
Founding Member 2006
Joined
·
109,002 Posts
On the license plate bulb, 2 thoughts
1. is it an led bulb or oem non led?
2. the wiring loom passes through the trunk to the rear sam and where the trunk opens and closes, if it kinks, it will break. this usually will also produce rear light issues and rear center brake issues so inspect the wiring loom.

one of many threads on the subject

http://www.slkworld.com/slk-r171-general-discussion/186769-led-boot-trunk-brake-light-question.html

edit: so if the cel comes and goes, it could be the loom flexing the break back and forth
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #3 ·
Sorry, I should've been more clear. I was referencing two different issues. One is the CEL coming on yesterday (got it scanned and was told it was an issue with the speed sensor) and not being on today. The other was an indicator letting me know that the license plate light was malfunctioning, even though it wasn't. By all indications it seems like an OEM light.
 

·
*Premium Member
2005 SLK55 AMG /2005 SLK350
Joined
·
6,197 Posts
I've had the CEL on and off before. Most recently due to manifold runners.

Try swapping the bulbs left and right. Sometimes just reseating the bulb will clear it up.
 

·
Founding Member 2006
Joined
·
109,002 Posts
Sorry, I should've been more clear. I was referencing two different issues. One is the CEL coming on yesterday (got it scanned and was told it was an issue with the speed sensor) and not being on today. The other was an indicator letting me know that the license plate light was malfunctioning, even though it wasn't. By all indications it seems like an OEM light.
I know 2 different issues. what i was saying is that because of the loom wire issue, you will get bulb out indications usually with license plate bulbs and 3rd brake light or brake lights
 

·
*Premium Member
2006 SLK55 AMG
Joined
·
415 Posts
Well...its been an "interesting" first couple weeks of ownership of my '05. Yesterday, my CEL came on, and fearing that it might be something major, like the balance shaft sprocket, I immediately took it to my local mechanic to he could scan the code. What he found was something relatively minor...something having to do with the speed sensor. Anyway, he said it wouldn't preclude me from driving it until I had some time to leave it with him.

Today, I climbed in and started her up. No CEL!! What gives? Anyone ever experience this sort of thing before? Does this car get periodic malfunctions that somehow clear themselves up?
Why do check-engine lights come on and go off?

"A modern PCM has to test more than 2,000 items on the vehicle. When we start the vehicle, we establish a "drive-cycle." This drive cycle continues until we turn the vehicle off. Not every test can be completed in every drive-cycle. This may add to the confusion of MIL operation.

When a test fails, the check engine light may come on. We start a new drive cycle and if the test that turned the light on does not run the MIL may turn off. This does not suggest we have solved the problem. The light is off because the PCM moves the information about the fault to history, and continues checking the problem. The next time the PCM runs the failed test, the light comes back on."

LINK
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top