Mercedes SLK World banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 98SLK230 would not start after a short drive. Not a click or anything. Had been starting and driving great until then. Had AAA come and jump started fine. Drove home and top would not go up, even with engine running. Would not restart, again not even a click. Put on my trickle charger for five days and no affect. Jump started it again, and with engine running top would not activate, and radio would go off when I was pushing roof switch. With motor off power door locks work but headlights do not come on. Battery was new last fall, and measures 38 volts while running and 35 volts when motor is off. Fuses look ok. I'm at a loss, and hope someone in this forum can help.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,272 Posts
Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!



You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.



Some tips to make your visit here more enjoyable:

If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member or guest will address your question.
If you wish to become PM (Private Message)- capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
New members and guests should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK World Forum
Thank you,
Jeff
Moderator/Founding Member
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,272 Posts
Most would say, get a new battery and see what happens. try a search top right, if you haven't already. some members will chime in

you said 38 volts and 35? not 18/15?
 

·
Registered
Joined
·
320 Posts
Start with the simple things. Check that your cables are connected to the battery good and tight and that there is no corrosion build up on them. Then try a new battery, maybe the battery has shorted out inside or something. A bad battery can do a lot of weird things to these cars.
 

·
aka John
Joined
·
13,012 Posts
What they said - most Auto parts stores stateside will do a free battery test. I'm assuming the 35/38 volts is a miss-type, else you have some major problems..
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Battery checked out ok

Took the battery to auto parts store. 12.80 volts, 827 CCA, so better than rated 770 CCA. (My cheap little multimeter must be bad.) I wanted to drive over, but could not jump car today ... Only got a click out of it, nothing else.

So, got home and put the battery back in. On a whim, I put in the ignition key and the car started right up! I was also able to put the top back up, and everything seems normal.

So, I'm one confused SLK guy. Don't know if my car is all good or it will die on me sometime in the future.

Any ideas as to what is going on and what I need to do?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,272 Posts
connectivity? bad battery cables now in alignment?
 

·
aka John
Joined
·
13,012 Posts
I'd check the terminals and the battery leads for corrosion as a starting point now that the battery has tested good. Normally the leads are "ok" if you can jumpstart the car, but never hurts to check.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,272 Posts
John! get out of my head!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #11
Thanks to all for your suggestions. Cables look good and were tight, no corrosion (a little petroleum jelly does wonders). I guess it will be wait and see, but am still mystfied why jumping it didn't work earlier.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,272 Posts
certain way to jump batteries. forgive me. but one was grounded, right?
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top