Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I just bought a 98 SLK 230 from a family member which took excellent care of the vehicle. I am getting a code for the camshaft positioning sensor and the mas airflow sensor. I am going to change them out to day and I needed to know how I would go about resetting the codes after I have done the install. Can anyone walk me through it with a step by step?
 

·
Founding Member 2006
Joined
·
108,819 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Founding Member 2006
Joined
·
108,819 Posts

·
*Premium Member
2005 SLK55 AMG
Joined
·
11,537 Posts
Hi and welcome to SLKWorld.com from the UK Midlands - Thanks for joining us! :)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I am going to start with these minor repairs and have the codes reset by a scanner. I believe that this car has more get up and go than it has been showing me. I read a few blogs that if the Camshaft Sensor is faulty it would limit power and the super charger would not engage.
 

·
*Premium Member
2019 SLC300
Joined
·
2,858 Posts
Check with dealer as they might replace the camshaft sensor free and put in a wire patch. The camshaft sensor as been know to leak oil and it wicks into the wires. A few years back MB did a service champain for the dealer to replace free of charge and do a wire patch. Some people reported dealer replaced other items as the oil had wicked and did damage down line. Does not hurt just to check with MB dealer on this and possible save you some money in the process.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
So I disconnected the negative terminal. Took off the old camshaft sensor, installed the new one. Reconnected the negative terminal started the car and the check engine light went off, ran fine. Drove down the road and it stalled at the stop sign. Started back up but it kept dying. It idles rough and is getting above average hot. Suggestions?
 

·
*Premium Member
2009 SLK55 AMG
Joined
·
14,628 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!
 

·
Premium Member 2007 SLK280
Joined
·
249 Posts
So I disconnected the negative terminal. Took off the old camshaft sensor, installed the new one. Reconnected the negative terminal started the car and the check engine light went off, ran fine. Drove down the road and it stalled at the stop sign. Started back up but it kept dying. It idles rough and is getting above average hot. Suggestions?
That sounds like a CRANKSHAFT position sensor issue, not a CAMSHAFT position sensor. I had the exact problem (as have many others, it is a common SLK issue I've come to understand). My car was running perfectly until a road trip back from the mountains it suddenly died while driving. Took me a few minutes to start it back up and it was fine for another hour or so and did it again. Until replacing that CPS the problem with stalling or not starting got worse and worse until finally I was unable to start it at all. I thought I had bad gas in it so I pulled the gas out, dumped in additives to soak any water or varnish and filled it up again to no avail, eventually the $60 CPS and 10 minutes was all it took to fix me up.
 
  • Like
Reactions: 98owner

·
Registered
Joined
·
9 Posts
Discussion Starter · #16 ·
I've read a few blogs saying it will take sometime for the EUC to calibrate to new driving habits. When I disconnected the negative terminal I also went through the steps of resetting the windows and the accelerator reset by holding down the accelerator for five seconds and waiting for two minutes before restarting the vehicle. Is there any possible way that it may just need to calibrate and work itself out over some time and mileage?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #17 ·
Ok, couldn't take it any more. Took the new sensor out and put the old one back in, everything went back to running smooth but no get up and go. Funny thing with the new sensor I felt more power between stalls, and sputters. It wasn't a OE sensor, some knock off brand that may have been it. I'll try OE and let ya know how it works out.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top