Mercedes SLK World banner

1 - 11 of 11 Posts

·
Registered 1998 SLK230/2001 SLK230
Joined
·
39 Posts
Discussion Starter #1
My 2001 SLK 230's battery drains when parked for a week or so. I bought a $40 UNI-T UT210E clamp ammeter and measured current at the battery. It shows zero, but every 4 seconds there is a momentary pulse to 20 something mA. I pulled fuses until it stopped. The culprit was Fuse 9, which is the PSE. Is this normal behavior for the PSE?

A few weeks ago I removed the PSE and found no damage other than some corrosion on the two multi-pin connectors. I don't know what else I can do with the PSE.

I am using a float charger currently (get it?) to prevent battery discharge.

I'd appreciate any suggestions.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,360 Posts
We know that the slks all need great batteries and will go 'dead' after 7 or 8 days if not on a trickle charger. As you know, they have many computer systems always running :D
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
4,953 Posts
I park both my R171's for months in the winter, and often for weeks in non-winter, with no trickle charger, and have never had a problem or flat battery.

R170 PSE performs the alarm function, do you only see this when the alarm is armed?
 

·
Registered 1998 SLK230/2001 SLK230
Joined
·
39 Posts
Discussion Starter #4
My 1998 SLK doesn't drain the battery either. The 2001 SLK has the problem. The PSE is acting as if something's awake in the car. Maybe it thinks a door is open?
 

·
Registered 1997 SLK230
Joined
·
219 Posts
I seem to remember reading in WIS that the quiescent current draw is considered as in spec if it does not exceed something like 25ma. Also how accurate is your clip on meter at such low currents?

The pulsing is odd. I am wondering if what you are seeing is the flashing Alarm LED current draw.

Sent from my SM-T710 using Tapatalk
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,594 Posts
Hi,

I've never tried it on the R170, but our C Class and S Class (which have much more Electronics), take around 4 weeks standing without a non start situation.

25mA is definitely acceptable with a decent and under 4 year old Battery.

FWIW every time a Battery goes flat it loses a little reserve Capacity, so it's not an ideal situation.

I try my best to drive all my Cars at least once a week, and do the same if I have a long term Customers Car here.

All MB's I've ever known since the "722.6 Transmission era" (1998 upwards roughly) need a good strong Battery or all kinds of Gremlins pop up due to low voltage upon Cranking. So even if an MB starts every morning, it doesn't mean the Battery is good.

Some later model MB's, (and other Cars) now have 2 Batteries, one purely starts the Engine, the other takes care of all the "Convenience" circuits.

Heavy Discharge tester is the only way to know for certain if the Battery is any good.

HTH, Cheers Dave
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,594 Posts
ATA Switch on control panel in front of gear lever nearby Hazard Switch ;)
 

·
Registered 1998 SLK230/2001 SLK230
Joined
·
39 Posts
Discussion Starter #9
ATA Switch on control panel in front of gear lever nearby Hazard Switch ;)
Thanks. Mine does not flash. That's another PSE clue.

You folks are correct that 25 mA pulsed is not enough to drain the battery. I removed the float charger and I'll remove the PSE when I have more time to inspect and clean it than I did last time.
 

·
Registered
Joined
·
82 Posts
anti-tow-alarm LED will not flash if ATA is switched off. I think you have to hold the switch for a few seconds and after locking the car it starts to flash.
nevertheless, I have 2 flashing LEDs (ATA and normal alarm LED on the radio) and I have constant 20mA draw when car is "in sleep".
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,594 Posts
Hi,

In MB Terminology, ATA = Anti Theft Alarm , not Anti Tow Away.

I don't have the Standard Radio, my entire Alarm System works fine, and the only LED that I have, (in the Switch), can be observed as flashing slowly when the Alarm is set by locking the Door with Key Fob ;)

Anyone else ??????????????????

Mine is 2002 Facelift SLK 320

May be it is a model / year or territorial thing ??????????????

Another thing I see often enough is that some numpty has fitted a good used PSE Pump, but only done half the job, so not bothered to Version Code it correctly on DAS / HHT Win which plays havoc with the Alarm.

Mine did not work properly until I set all the version codings properly :wink:

HTH, Cheers Dave
 
1 - 11 of 11 Posts
Top