Mercedes SLK World banner

1 - 17 of 17 Posts

·
Registered 2012 SLK55 AMG
Joined
·
12 Posts
Discussion Starter #1
Hi all. Has anyone else had a similar issue to me and my AMG55 R172 2012.....Hoofing up through the gears, whether in C S or M, it will accelerate fully till about 6000 then hold back really noticeably for 2 or 3 seconds, before resuming full bore acceleration again for the last 1000 revs. Very annoying and as the auto box wont change up till the red line unless i get in there first, (which is not the point) i'm left with staccato bursts instead of a lovely linear increase. Any thoughts would be greatly appreciated as with the current pandemic, no dealer facilities are available for the foreseeable future.
All the best, Neil.
 

·
Super Moderator UK SLK 55 AMG 2007
Joined
·
27,228 Posts
@b82012
@MartinatMersea
@VII7
@Trev5
@nimbusgb
@Dave2302

Try this:

Possibly time for a tranny service ( some MB Indy garages are open).
What mileage?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,338 Posts
this is after a proper warm up to 80c i assume?

then time for techron or similar :D

 

·
Premium Member 2018 SLC43
Joined
·
2,600 Posts
I'd also guess at engine, over Gearbox...

Have You checked that the Exhaust Flaps are working correctly....??
 

·
Premium Member 2012 SLK55 AMG
Joined
·
6,162 Posts
The manual clearly says to avoid full output of the engine when the oil temperature is below 80 degrees centigrade. I think there maybe a rev limiter to prevent damage but happy to be corrected. You could also try to reset the adaptive learning for the gearbox. When was it last serviced and by who ( Main Dealer, Independent)? Has the car received all of the Software updates. Mine has had at least 5 updates for various control units including engine, transmission, fuel pump etc. since 2017 when I first owned the car. Are the exhaust flaps working correctly?
 

·
Registered 2012 SLK55 AMG w/P30
Joined
·
3,470 Posts
I can tell you from personal experience, the M152 runs to red line ice cold very happily.
 

·
Registered 2012 SLK55 AMG
Joined
·
12 Posts
Discussion Starter #8
Just over 51000 miles. The transmission was serviced with a fluid change 10000 miles ago and I never give it th berries before 80c oil temp.
Many thanks for the suggestions I will try the reset for the way home tonight, it's more an engine holding back issue than a gearbox not changing up issue though.
Jeff I have updated my profile to include the year now
I'd also guess at engine, over Gearbox...

Have You checked that the Exhaust Flaps are working correctly....??
Interesting you mention the exhaust flaps..as when it takes off again for the last 1000 revs, it does change sound and growl a lot deeper. Would that have an effect?...and how can I check they're working?
The manual clearly says to avoid full output of the engine when the oil temperature is below 80 degrees centigrade. I think there maybe a rev limiter to prevent damage but happy to be corrected. You could also try to reset the adaptive learning for the gearbox. When was it last serviced and by who ( Main Dealer, Independent)? Has the car received all of the Software updates. Mine has had at least 5 updates for various control units including engine, transmission, fuel pump etc. since 2017 when I first owned the car. Are the exhaust flaps working correctly?
Hi, I think you may have misinterpreted what I said...I never stress the engine until it's past 80'oc so protecting rev limiters wouldn't apply here.
The car has only ever had main dealer servicing so I am assuming all applicable updates have been carried out. Again, with dealers being shut it's difficult to do much on my own.
It was serviced at the supplying main dealer 4 months ago.
Can the exhaust flaps be checked easily?
I can tell you from personal experience, the M152 runs to red line ice cold very happily.
Yikes!!?
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,338 Posts
:D I saw the year addition...i see all.... ty....:D
 

·
Premium Member 2012 SLK55 AMG
Joined
·
6,162 Posts
@116nellie never assume that the dealer will apply software updates automatically when the car is serviced. On mine a couple of the updates could have been applied several services before they were. I always now make a point of asking them to check.
 

·
Premium Member 2012 SLK55 AMG
Joined
·
6,162 Posts
I can tell you from personal experience, the M152 runs to red line ice cold very happily.
Avoiding full power before the engine oil reaches 80 degrees C is from the manual. I have never redlined my own car at any temperature so I have no experience their.
 

·
Premium Member 2018 SLC43
Joined
·
2,600 Posts
@116nellie never assume that the dealer will apply software updates automatically when the car is serviced. On mine a couple of the updates could have been applied several services before they were.
Same with My R171/350 - They only applied an 7G Gearbox software update after I said it hesitated very occasionally when hot...
 

·
Registered 2012 SLK350
Joined
·
783 Posts
It sounds like a changeover problem, likely adjusters or intake actuators.

This does not sound like a transmission problem from the description.
 

·
Premium Member 2012 SLK55 AMG
Joined
·
2,495 Posts
Sounds exactly how mine behaved with a failed exhaust flap actuator. To check turn on the ignition but do not start the engine. Inspect the flaps, if one is static and the other continues to cycle between open and closed. The static one is either disconnected or has failed.
 

·
Registered 2012 SLK350
Joined
·
783 Posts
Sounds exactly how mine behaved with a failed exhaust flap actuator. To check turn on the ignition but do not start the engine. Inspect the flaps, if one is static and the other continues to cycle between open and closed. The static one is either disconnected or has failed.
Ah right always forget the exhaust flaps on these, I would start there too.
 

·
Registered 2012 SLK55 AMG
Joined
·
12 Posts
Discussion Starter #16
Yep, one static, one cycling.....so at least I now know what the problem is. Just gotta wait a few months till a dealer opens up their workshop now.....still, in the grand scheme of things this problem is nothing compared to what some people are going through.....I can wait.
Thanks guys for the help
 

·
Registered 2012 SLK55 AMG w/P30
Joined
·
3,470 Posts
The part that threw me off, I thought about the exhaust flaps, was because he said it would pause and then continue on. With exhaust flaps it’s my understanding that when malfunctioning it would be limited and it will not go any higher at all.
 
1 - 17 of 17 Posts
Top