Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 18 of 18 Posts

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
First of all let me say I'm sorry. I know these are posted up on here often. My setup, of course when I was looking for after markets 90% of them seemed to have easier install plug n plays but did I take the easy route no...

05 SLK 350 no comand (does have CD changer)

So I have been trying for several days to get this to power on with no avail.


This is wiring setup I am attempting to use..
How is have it setup

Quadlock is just straight inserted

For the B portion
Yellow is Tied in 12v on QL
Red is tied into 12v on cigarette lighter
Black is tied into ground on QL
Blue amp is tied into 12v on QL (Removed)
Illumination is tied into 12v on Cigarette lighter

Those are all I have used right now but I have no power of the head unit.

Thank your for any help!
 

·
* Registered
2006 SLK350
Joined
·
229 Posts
Typically on aftermarket units the blue wire supplies +12V from the head unit to turn on an amplifier or power antenna, usually labeled "remote" If you have that connected to 12V+ from the car it could be causing your problem. Other than that double check your connections and fuses.
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #3 ·
Does anyone have a color coded layout of the wiring diagram. The quadlock that is built into the car. Seems to show that Orange/Blue is Ground. And light tan/cream is 12v does that seem right?
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #5 ·
These are the 2 wires it's showing me in every diagram are the 12v and ground.

Don't mind the snip of the ground, I need it longer so I have it tapped straight into quadlock connector
 

·
* Premium Member
2008 SLK 350
Joined
·
3,004 Posts
Does anyone have a color coded layout of the wiring diagram. The quadlock that is built into the car. Seems to show that Orange/Blue is Ground. And light tan/cream is 12v does that seem right?
Here you go. No Comand you say and US so must be Audio 20. Wiring diagram for pre-FL US version. And some help how to read them.
 

Attachments

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #7 ·
It is Audio 20

So I tested the power to every wire I stated above. They all have 12v. Still not powering on.

I have the illumination and ACC redwire tapped into the Lighter.
 

·
* Registered
2006 SLK350
Joined
·
229 Posts
Power and ground from the car to the radio needs to happen on the quadlock connector for sure, as that is where the fuse in the head unit is. When I look at "quadlock connector 1" in the instructions it shows power and ground in the same locations as the wires snipped in your picture from the car's quadlock connector. I might be missing something but it looks like it was supposed to be plug and play.


Connector B on the head unit is labeled "cam input" in the directions in the upper left corner. Have you tried powering it on with the black and red from connector B disconnected? I'm not sure what those are labeled as but wondering if they are power leads for an accessory such as a rearview camera rather than power input.
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #9 ·
The quad locks are designed to be plug and play, the problem I was/am having is the "ground" from the car quadlock, wasn't grounding. It was testing as an active line as well. (I had tried straight plug and play initially before starting to test/tinker) I have everything grounded and testing at the proper voltages (from the quadlock)

Connector B is all wired up.

Yellow to yellow / black to black and red and orange are wired to the lighter
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #10 ·
Sooo some good news I got it setup and figured out but now I have other issues. so when trying to wire the SW it was throwing every code you could possibly imagine and glitching. I wired sw1 to the red/brown. So I currently have it disconnected and no errors when it's off.. problem 2: Check engine light popped on and is throwing a ton of errors looking as though they are ECM related guessing this is from a wire that was in the quadlock or something.. Really hoping someone has had this issue!
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #11 ·
Just curious if anyone has any idea how to setup these SW controls. Got everything else figured out but I cannot get these to work.
 

·
* Premium Member
2008 SLK 350
Joined
·
3,004 Posts
Just curious if anyone has any idea how to setup these SW controls. Got everything else figured out but I cannot get these to work.
If I read the very brief description of the Erisin ES8184S on their website, they say it has in in-build CAN decoder. SW controls are CANbus messages. In their wiring overview there is however no mention of a canbus connection. Closest is indeed the SW controls.2 wires. Canbus consists of 2 wires canh and canl,canh is brown/red and canl is brown in MB vehicles.In your old radio that was pin 11 and 9 of connector 2.
Pin 11 being canh and pin 9 being canl. Now Erisin should have specified whether the 2 SW wires are indeed for the can connection and which one is canh and which is canl. But let's assume it is then probably they would have the same colour as the original wires. So you would need to connect them to the matching wires of pin 11 and 9 of the original connector 2.
If that is correct,last step is to program the Erisin. Probably there is a setup menu where you can program the function of your steering wheel buttons.
Did there not come any documentation with the unit?
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #13 ·
When I plug the SW1 into the the canH. It throws the electronic system into a tizzy and throw every error imaginable on the dash. Is this normal before programming?
 

·
* Premium Member
2008 SLK 350
Joined
·
3,004 Posts
When I plug the SW1 into the the canH. It throws the electronic system into a tizzy and throw every error imaginable on the dash. Is this normal before programming?
No,that is not normal. Probably connecting it messes up the canbus.
So you need to find out what SW is. Is it a canbus connection? Is it something else? What does the manual say? Did there even come an installation manual whit it. And what do you mean with SW1? Is that wire #1 of the SW wire pair? How do you know it must be connected to canh?
 

·
* Registered
2005 SLK 350
Joined
·
19 Posts
Discussion Starter · #15 ·
The manual says it's SW and SW1. Specifically Steering Wheel and Steering Wheel 1
 

·
* Premium Member
2008 SLK 350
Joined
·
3,004 Posts
And does the manual also say whether this a canbus connection and which wire is canh and which canl?
 

·
* Premium Member
2008 SLK 350
Joined
·
3,004 Posts
Then I am afraid the only option left is try and error. Try sw1 on canl and sw on canh. If that does not work switch them,sw1 on canh and sw on canl. If that does not work either it is time to call in support from Erisin. I have no clue either then. Sorry.
 
1 - 18 of 18 Posts
Top