Mercedes SLK World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 230 K has been sat for the last 4 months. Took her out for a spin today and after about 80 miles the cruise control suddenly switched off and the ABS and ESP warning lights lit up on the dash. The ABS is not working and am wondering if this is just because the car has been stood for so long and would a good clean do the trick or am I looking at buying a new ABS unit?
 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts
Welcome from Valrico, Florida!
And welcome to this great forum!

Please update your location/vehicle (model and year) in your profile as it helps the members answer any questions you might have based on your location and model and year.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘vehicle’ and ‘location’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.





If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.
 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts
i believe you can reset the abs. do a search. something about switch in position 2 and then turning wheel left and then right
 

·
Administrator - Founding Member since 2006
Joined
·
94,112 Posts
1 - 5 of 5 Posts
Top