Mercedes SLK World banner

Status
Not open for further replies.
1 - 18 of 18 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hey Guys, I need a little bit of help...

So I brought my r170 in yesterday to a mechanic because my speedometer/odometer/cruise control hasn't worked and the check engine/ESP/ABS lights have been on since I bought the car about a month and a half ago. After spending a few hours with the car he told me (and I apologize because I don't really know what I'm talking about) that the car's traction control/hydraulic brake/ABS module (? he used a few different names each time i spoke to him) was faulty, and it was causing my problems. He told me he'd have to replace the module "and the assembly" and quoted me for $1,825 ($330 for labor, $1,495 for the part) since he could only get the part from the dealer.



He said He'd be fine installing the part if I were able to buy it used and bring it to him, so I'm hoping I can save a little bit of money if possible by finding it on my own. I know the part number for the module (0034310312). This may be a bit of a stupid question, but can anyone help me figure out what exactly he meant by the assembly, if it has a separate part number, etc? I'd really appreciate it.


...is it all of this?


Thanks a lot!
 

·
Premium Member 2002 SLK230K
Joined
·
17,144 Posts
The ESP light can be reset by turning the steering wheel from stop to stop then back to center. Post the codes before you spend money.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Well when I took it into him, he hooked it up to a STAR system (on two separate occasions, actually) and reset all the codes in the car. The lights all came back on before it was even moved an inch. I'm not sure what the exact codes were..
 

·
Registered
Joined
·
54 Posts
Any fix on this? What happened? I just bought a 2002 slk and I have almost all of the same problems you have.

My speedometer doesn't work and the ABS/EBS/Brake lights are all on. Everything else including tach, fuel, temp reading, etc...work great.

I also have the rearview mirror issue, and I was also wondering about the operating temp as well, so thanks for getting that one cleared up for me :).

Let me know if you've figured anything out on this issue. I bought the car knowing it had these problems, so hopefully I can get it fixed without having to pay too much :).

Such a fun car to drive otherwise.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,266 Posts
wasatchmountains,


Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!


Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.




If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message)- capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
New members and guests should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under quick links when you leave.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK World Forum
Thank you,
Jeff
Moderator/Founding Member
 

·
Premium Member 2006 SLK 280-sold
Joined
·
3,552 Posts
Any fix on this? What happened? I just bought a 2002 slk and I have almost all of the same problems you have.

My speedometer doesn't work and the ABS/EBS/Brake lights are all on. Everything else including tach, fuel, temp reading, etc...work great.

I also have the rearview mirror issue, and I was also wondering about the operating temp as well, so thanks for getting that one cleared up for me :).

Let me know if you've figured anything out on this issue. I bought the car knowing it had these problems, so hopefully I can get it fixed without having to pay too much :).

Such a fun car to drive otherwise.
The first thing I would do is to take it to a place like AutoZone and have them read the codes for you. Get a printout on every code and come back here and post them in this thread or create your own. You should also search the forum for these codes and the problems you are having and read up on them.

Luckily it looks like your car is driveable so you may have time to solve the problems. I would do it soon, though, as some CEL's are trivial (ambient air temp, Gas cap loose, etc.) but most are not, and some can be tragic.

Best Wishes
 

·
Registered
Joined
·
54 Posts
Thanks for the quick response. I did take to autozone already but their readers don't pull anything. Perhaps because the check engine light isn't on their readers don't see the problems with sensors.

I'm trying to find a local mechanic that has a Mercedes specific reader to hopefully get more detail.

I'll be sure to let you all know...fortunately for me, I have the 6 speed manual and the car still drives great, just no ABS, ESp or speedometer.

The no speedometer is the biggest concern as the only way I can tell how fast I'm going is by looking in the mirror to see how big my smile is :)
 

·
Premium Member 2006 SLK 280-sold
Joined
·
3,552 Posts
Here's a piece of info, and granted it's for an R171. I went to Advanced Auto parts, and they plugged in the OBD reader and couldn't get a code. I went across the street to AutoZone and they did the same thing - but with some more specific instructions about when to start the car, turn the key, etc. (Sorry but I'm old and can't remember exactly what the differences were) They were able to read the codes.

Granted - I had a CEL, so it may not matter. However - you may want to try somewhere else.
 

·
Premium Member 2001 SLK320 Wizard of ID
Joined
·
589 Posts
My OBD reader reads my 170 just fine.

Yes, please post the codes here when you are able.

Did you try the "steering wheel lock to lock" procedure?
 

·
Registered
Joined
·
54 Posts
Thanks tcrankwa. I have done the lock to lock a few times. The lights come back on after about two seconds.

Hopefully Timdojo will make some progress on his issues to help point me in the right direction.

I'm going to stop by another car parts store today and hopefully get some more info. I'll be sure to post any codes that come up.
 

·
Registered
Joined
·
25 Posts
Hi Tim/Wasatch

I had problems with my ABS/ESR unit and got one from a breakers (you'd probably say salvage yard), via e-bay would you believe and my local garage fitted it. After finding out the one I'd got also had a HP return fault on it, I returned it and got another, it was fitted and ba-dah-bing, all well. Garage zeroed off the codes and so far no further probs, and thats been 2 months. Don't panic, second hand parts will work as long as you ensure you match the numbers on both parts of unit. Nothin beat the feeling of getting it fixed for a total of £190 as opposed to £1600 the MB stealership wanted. Good luck
 

·
Registered
Joined
·
54 Posts
How do you get the ESP/ABS unplugged?

So I've checked with multiple car parts stores and none of their readers find anything.

So, I'd like to remove the unit to inspect it, but I cannot figure how to unplug it.

There is a section where all of the wires plug into the unit but I can't seem to figure out how to get it unplugged for removal and inspection. Any ideas?

My unit looks a little different then the one posted by Timdojo. I'm going to try to attach a picture of what I'm talking about.

Thanks for any help you can share!
 

Attachments

·
Registered
Joined
·
333 Posts
Here is my contribution on this subject. My MB (07 350 w/auto) kept giving me the message that the ESP was unavailable. In addition to this issue, I lost the cruise control. I tried all the tricks and tips that our fellow owners provided on this forum, but nothing worked for me. I finally caved and took my car to an MB dealer, and they fixed the problem for me. I just had this done last Wednesday (08/01/12) so the data and price should be current, at least for Tafel Motors in Louisville, KY. I can not fully understand the invoice that is lying before me, but it appears that the control unit number is 171-545-16-32. At least that number appears beside the description of Contol Unit. There is another number on the invoice that I have no clue what it means, but it just may be the code number. It is 732 CM1. To add to the confusion, there is another number which is 73642 which is at the front end of the line which reads: Found steering angle sensor bad. Replaced steering angle sensor. Now to the critical part. Labor was 287.50 USD, part was 226.80, misc 14.38, and sales tax 14.47 for a grand total of $543.15. I drove away a happy man. I hope this helps the discussion rather than confuses it.
 

·
Registered
Joined
·
54 Posts
WAHOO!!!!!!! I found a used ABS module on ebay, just got it in tonight. I also pulled all of the speed sensors off and cleaned them and now I'm in business. Speedometer and top are all working now!!!!!! THIS IS AWESOME!

Thanks to all of you that helped me figure this out
 
1 - 18 of 18 Posts
Status
Not open for further replies.
Top