Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 14 of 14 Posts

·
*Registered
2004 SLK200
Joined
·
30 Posts
Discussion Starter · #1 · (Edited)
Hi All,
I am trying to boost the antenna signal of my R171 originally equipped with a A 171 820 00 89 amplifier.
I purchased a used A 230 820 12 89 module as it seemed to be a reasonable suggestion.
I would need some help in figuring out how to connect the new module:

The 3-wire power connector is identical.
There are four shielded cables out of the connector with cut cables: they have black, yellow, red, and blue ribbons, respectively.
On the other side (left in the picture and not shown) there is another 4-pin connector as the one on the right (no cut cables came with the module and one of the pins is blind).

Any help in what to plug to the trunk antenna and to the head unit connectors?

Thanks!
 

·
*Premium Member
2008 SLK350
Joined
·
3,491 Posts
I am starting to believe I purchased the wrong piece... EPC labels it as front panel amplifier.
I think so too. Though it is an antenna amplifier from the SL R230.
But the bad news is that the SL has an antenna assembly consisting of 4 amplifier units. By the looks of it you purchased the left antenna amplifier module. According WIS this one amplifes AM and FM signals. So far so good. Bad news is that another module handles the remote unlocking/locking, RRCL as it is called in the SL. (Remote Radio Central Locking ?)
Long story short,IF (and that's a big if) you even got it to work you would probably not be able to lock/unlock the car with the keyfob.
If I were you I would try to sell and get a proper amp for the car, the A171.... one.
Would be a nice project though to get it to work. Challenging...... 😁 ;)
See attachments for some info.
 

Attachments

·
*Registered
2004 SLK200
Joined
·
30 Posts
Discussion Starter · #6 ·
Hi All,
the amplifier upgrade was put no hold, and I would like to get back to it and find a solution for the poor reception.
Anyone could suggest a compatible amplifier to obtain a decent signal? I believe I should stick with SL parts, but I am uncertain if that might be a direct swap with the piece I have now (A 171 820 00 89).

Thanks!
 

·
*Administrator (Premium Member)
Joined
·
40,843 Posts
Do you have the stubby, or long aerial? The long, whiplash aerial has better reception.

This might work if a stubby and you do not want whiplash type:

Although for 170, it may work for 171.
 

·
*Premium Member
2007 SLK55 AMG
Joined
·
2,745 Posts
I've had a modded r170 antenna on my car since 2008 and it works from >200 feet, mod done by etyu. Ahh, the good old days...
 
  • Like
Reactions: Avel Du

·
*Premium Member
2008 SLK350
Joined
·
3,491 Posts
Just a question. In another thread you mentioned replacing the OEM radio by an aftermarket one. Did you do that and did bad reception start after this swap? Reason for asking is that the antenna amp is switched on by a signal over a seperate wire from the OEM radio. Something that is not done by an aftermarket radio. Bad reception could just be due to the fact that the antenna amp is not switched on.
 

·
*Registered
2004 SLK200
Joined
·
30 Posts
Discussion Starter · #10 ·
Thanks all!
I never had an OEM long antenna (R171 820 0089), I purchased the car with a (very) short aftermarket antenna.
I replaced the head unit with an android device short after that and, honestly, I can not really tell if the radio reception got sensibly worse because of that.

I tried (android radio on) to install a short OEM antenna (R171 820 1775, which is, however, longer than the aftermarket one) with no sensible improvement on the reception.

My current setup is:
Android radio,
A171 820 1775 Antenna (OEM, yet shorter than the original),
A171 820 0089 Amplifier.

I figured out a couple of possible steps:

1. It may well be that after the head-unit change the antenna amplifier is not powered up correctly.
How can I check this?

2. I see the A171 820 1775 short antenna is coupled with an amplifier (A171 820 5589) which is different from the one I have.
Would changing the amplifier do any good?
 

·
*Registered
2004 SLK350 R171
Joined
·
105 Posts
I recently switched my head unit out, zero radio reception, I don’t listen to a lot of radio so it’s technically not a problem, but I’d like to sort it.
Did you have any joy?
 

·
*Administrator (Premium Member)
Joined
·
40,843 Posts
I recently switched my head unit out, zero radio reception, I don’t listen to a lot of radio so it’s technically not a problem, but I’d like to sort it.
Did you have any joy?
OP has not visited in two months.
This is why we always recommend quoting (as I have done with you) or
mentioning, as I will do with OP below.

@bonilla
 

·
*Registered
2010 SLK55 AMG
Joined
·
1,678 Posts
@Thresherinc Have a look at the radio settings.

Mine was set to "Europe" (which is kind'a obvious since I'm IN Europe :) ). However, I had lousy radio reception as well. Just for laughs, I changed it to China (because it's the first one in the list - thought I'd go through them one by one to see which one worked best). But it instantly worked perfectly!
White Light Motor vehicle Automotive design Vehicle
 
1 - 14 of 14 Posts
Top