Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Got stuck at the mall today when my 55 would just keep cranking, but not fire. After letting it sit for like 15 minutes it started, but now the CEL is on. After searching the world wide internets it sounds like the CPS (crankshaft position sensor). Going to get it diagnosed on monday to be sure, but really sounds like this is the problem. Has anyone else here experienced this? Can I pick up the part online somewhere? Is it a DIY kinda job? Thanks alot!
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,217 Posts
i would ask how old your battery is first
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,217 Posts
ok, just checking.
 

·
Registered
Joined
·
500 Posts
Got stuck at the mall today when my 55 would just keep cranking, but not fire. After letting it sit for like 15 minutes it started, but now the CEL is on. After searching the world wide internets it sounds like the CPS (crankshaft position sensor). Going to get it diagnosed on monday to be sure, but really sounds like this is the problem. Has anyone else here experienced this? Can I pick up the part online somewhere? Is it a DIY kinda job? Thanks alot!

The part is around $30-$40 and just a screw holding it. It very easy to replace. It located on the back of the engine (driver side) between the engine and tranny meet.
 

·
aka John
Joined
·
13,012 Posts
Quickwi's right, it's a know potential problem. Good news is it throws very specific codes, so that's your first step!
 

·
Registered
Joined
·
270 Posts
Thanks for the help gentlemen, where would you recommend pickin up the part?
Get your car to the dealership or any reputable independent shop who can properly diagnose the problem. That would be your first step :)

Last thing you want to do is spending your money on parts you didn't need..

Good luck
 

·
Registered
Joined
·
78 Posts
Discussion Starter #11
Put the scan tool on it today and it is the CPS, now where do you recommend I pick one up? Stealership here wants $216 and most US parts sites dont seem to want to ship it to Canada.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #12
Got the part in from amazon today and installed it, total job took $100 and 15 minutes, glad I did it all myself. Thanks for all the help guys!
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top