Mercedes SLK World banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
I suspect there is an issue with the module. Previous owner said he had a code, changed it, code went away.

He grabbed 2 from a junk yard. The origional and a junkyard acquired part were in the trunk.

I get no fan unless I turn on the heat/ac

Can anyone you tell me which is the original part by looking at it?

Also, the alternate has a different part number and other numbers and letters on the sticker. Are they both interchangeable in my 2004 230? (82000 miles)

I also don't know if the one currently in the car is either one of these models, but will start here, open them and see if they are in working order visually, etc

Ide rather diagnose this before changing sensors, thermostat, etc
 

Attachments

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
ok, i looked into this further. I opened one of the 2 in the trunk. it was the same part number of the one in the car. It was fried for sure. See photos.

I also opened the darker grey one that said ESG600 on it. It looked very nice inside but i do not know if its compatible with the car. Does any one know if i can use it? looking online it looks like its for a CLK not an SLK.

Any gurus have any info on this?

Thanks!

pics are of the burned unit that was previously on the car. I am going to open the junkyard part tomorrow which is currently on the car. The one that says B on it is from the part i suspect is for an CLK. ESG 600
 

Attachments

1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top