Mercedes SLK World banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have a 2002 SLK320 that needs some TLC. It has a couple problems that I can't figure out, and I hope it's OK to include them both in one post.

1. The wiper fluid hose has detached from the sprayer nozzle. When I pull the sprayer out of its slot, I can see it's attached to wires, and I'm pretty sure I can see the hose it should connect to. I can reach the hose with needle nose pliers, but it won't budge. But when the spraper is back in its spot, it doesn't connect to the hose. The water just plops out?

2. Just recently, I hear a sound like radio static or soft air escaping. It's constant as long as the car is running. It still makes this noise when AC fan and radio are both off. The AC is till working. It seems to be coming more from the passenger side. What could it be?

Thanks for any suggestions! Aloha!
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,272 Posts
moving from homepage news to r170 general discussion...homepage news is the front page for the froum!!
 

·
Premium Member 2006 SLK350
Joined
·
6,796 Posts
Regarding the washer hose...not familiar with the 170 setup, but is there a chance the hose has gotten wrapped around something a bit further "upstream" which has caused it to be pulled out when the hood was opened?

The hissing sound - any changes when you drive? Anything else misbehaving? I'm wondering about a vacuum leak?
 

·
Premium Member 1998 SLK230
Joined
·
3,526 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Der....I need to try to find the correct screw driver to take off a piece under the hood that will let me get a closer look at the hose path.

And, as for the noise...it doesn't seem to be affecting anything. The AC works fine, and my car drives fine as well.

Leapy....I'll research the changeover valve, as that is the location the sound is coming from.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Regarding the washer hose...not familiar with the 170 setup, but is there a chance the hose has gotten wrapped around something a bit further "upstream" which has caused it to be pulled out when the hood was opened?

The hissing sound - any changes when you drive? Anything else misbehaving? I'm wondering about a vacuum leak?

No changes when driving. Everything else works fine. I can turn off the radio and the fan, and it still makes this soft hissing noise that almost sounds like radio static? It's very weird!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
The sound may be a problem with the changover valve, Its located behind the glovebox.

I googled the changeover valve, and the issues it describe don't quite line up with what my car is doing. It makes a soft hissing noice, similiar to radio static. It's constant, and doesnt' change while driving, or when fan and radio are turned off? I just don't know?
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top