Mercedes SLK World banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone,
I recently purchased a 99 SLK 230 with the Bose sound system and have been working through the cars issues. I have two remaining issues that have me stumped. I took it to the only import shop in town and he told me the car needed to go to the dealer, which is two hours away.

1. The radio turns on but no sound comes out of the speakers. The fuse on the factory amp is not blown, but I see online there is a relay that turns the amp on. Can anyone tell me the part number or where it is located?

2. The right blinker does not work at all (no fast flash in the cab), however the hazards do work. I suspect the stalk is bad but don't want to throw parts at it.

I appreciate any help.
 

·
Minion
Joined
·
5,602 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Chicago IL USA!

Here are just a few easy instructions to make your membership a fun and productive experience:

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t already.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

The "Search" feature at the top right of the page is for searching the forum. Many questions have already been asked and answered by our knowledgeable members.
If you are having difficulty finding a solution, you can post your question in the appropriate discussion forum. By doing this, you should receive a quicker response, but please be patient as the forum is worldwide and members live in different time zones.

Private Message (pm) is a tool to communicate with other members privately for instructions or just chatting. In order to do this you must have at least 15 posts. It's easy to obtain the posts by clicking on the "New Members Introduce Yourself Here" section and just welcome the new members (like we welcomed you).
To post a picture, either start a new thread or reply to one, type what you want to say and click on the 'paper clip' just above, this will open a window to your left, click on 'browse', go to your pictures, and double click on the one you want to post, click on 'upload' and then 'submit' your post.

If you like a comment or want to thank another member for their post, there's a 'like' button to the right and just below is the 'thanks' button.
As a new member you can use the "New Posts" link at the top of the info bar. It's a great way to see all of the posts you have missed since you were on the forum last.

When you are ready to leave the forum just click on "Quick Links" and click 'mark forums read', this will clear your screen for when you log on again.
As a member you have the privilege to vote and/or enter our Ride of the Month competition, we welcome new SLKs to compete and new members to vote:
http://www.slkworld.com/rotm-submissions-voting/

If you have any questions/comments please let us know and we will be happy to help you.

Thank you
The slkworld.com minion
 

·
Minion
Joined
·
5,602 Posts

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t already.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.



Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Registered
Joined
·
36 Posts
hi Bimmerdan and welcome, hope you enjoy it here.
as far as the radio, have you tried the other inputs; tape/CD?
Pulled the radio out to check rear connections?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Please follow the DATA card link in my signature and post your VIN number so that we can pull the specs on your car for you. Congrats!
I cant quite yet, because I do not have 5 posts.

hi Bimmerdan and welcome said:
Thanks for the reply I have not yet pulled the head unit, I'm waiting on the radio removal tool. Both the CD changer and Tape have the same issue, I was looking forward to the MC Hammer tape I found :hb:
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
she means just post your vin right here or in the vehicle datacard request section
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
standby.....
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
Here ya go!
 

Attachments

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,411 Posts
ignore this:

DARK BLUE SOFT TOP FABRIC

data collection was not up to par in 1998 and 1999
we know you have a hardtop!
 

·
Registered 2004 SLK230
Joined
·
6 Posts
I had a similar problem with my radio except I had no power at all. Checked all the fuses and it was all good. Removed the radio and checked the fuse on the back and it was good as well. Reseated both harnesses and the system fired up. It's possible your speaker harness is loose.

Make sure you have your radio code before disconnecting the power.

If you have 2 small metal nail files you should be able to remove the radio without waiting for the official removal keys.

Alex
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top