Mercedes SLK World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
During a recent trip to spend a few days up in N. Wales my 1999 230 SLK developed a puzzling intermittent fault. Hopefully you can throw some light on it for me.


The symptoms are :-
When the engine is normally hot the red lights on the EC and Recirc. switches come on and stay on (operating the switches makes no difference) and the electric rad. fan stays on permanently even though the engine temp. stays constantly at 80 degrees. When this happens the rotary heater fan control will not operate at any setting.

When starting the car the following morning everything works and is fine until I switch the engine off when it is hot. Then, on restart, the above situation recurs.

A bit of a pain this weather with no aircon!!!!


Have you or any of your SLK colleagues come across a similar situation and, if so, what did you/they do to cure it?

Grateful for any leads you can provide.

Meanwhile kind regards - Tony D.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
98,481 Posts
Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!











If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.

If you wish to PM (Private Message) someone, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.



Thank you,
Jeff
Founding Member #12/Moderator
 

·
Premium Member 2002 SLK230K
Joined
·
17,144 Posts
Welcome from New Hampshire, the Rad fan issue sounds like a K40 problem. Do a search there is tons of info about this know problem.
 

·
Registered
Joined
·
3,381 Posts
Welcome from Michigan..... Hope you get your problem addressed!!
 
1 - 8 of 8 Posts
Top