Mercedes SLK World banner

1 - 11 of 11 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
My 1998 slk 230 had an issue while I was driving it one day and the gauges started to act up and the A/C quit working.
From reading the forum I was able to diagnose the gauges and ended swapping them out.
The gauges are working fine, but the a/c never did start working.
I thought it might be low on freon and took it to the shop, they checked it out filled the system and said that the compressor was not coming on.
I looked at the fuses I think feed the a/c and they are good.

My question is how to I test the clutch to make sure it is working.
Can I jump the wires on the pressure switch and if so which ones or is it better to just put 12 volt to the wire that feed the compressor.

Any other suggestions would be appreciated.

Bob
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,593 Posts
Hi,

To save yourself a headache and likely un necessary expense / time, get it on SDS, (not some cheap lesser machine), look at AAC and see what Fault Codes, look at live Data ("Actual Values") etc etc.

Anything else is pure speculation and guesswork with this type of fault, it could be a whole bunch of things, and the law of sod says it will be the last thing you look at :wink:

HTH, Cheers Dave
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4 (Edited)
A/c blows cold while driving and not at idle

The a/c is filled and working great when driving. When at idle it isn't cold at all. I narrowed it down to the silver finned controller on the fender. If I add power to the controller the a/c blows cold at idle.
What the issue is I am having trouble identifying the part number and name.
I looked on FPCEuro and saw this part which I think is it, and looking for a second opinion to be sure

https://www.fcpeuro.com/products/mercedes-engine-cooling-fan-controller-c230-c280-e320-slk230-0255453332

Thanks Bob
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,334 Posts

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,334 Posts
here from your vin

A 025 545 33 32
ELECTRO. TRS. CTRL. UNIT
AUXILIARY FAN
Replaces: A0275458132
Replaces: A0185459932

item 56 in the pic

 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,334 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #8 (Edited)
The issue was low freon and now the system blows cold while driving, but not at idle. If I put power to thie part in the picture the a/c will blow cold at idle.
I can't find out what the part name or number is or even if it can be tested

Thanks this site is great.
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
96,334 Posts
The issue was low freon and now the system blows cold while driving, but not at idle. If I put power to thie part in the picture the a/c will blow cold at idle.
I can't find out what the part name or number is or even if it can be tested

Thanks this site is great.
did u read my post 6 n 7 above?

it tells you the part number and part name and even where to buy it

part name.....part number

A 025 545 33 32
ELECTRO. TRS. CTRL. UNIT
AUXILIARY FAN
Replaces: A0275458132
Replaces: A0185459932
 

·
Registered 2002 R170 SLK V8 5.0
Joined
·
2,593 Posts
Hi,

Yes that is Cooling Fan Controller, it should come on when A/C is on regardless of Engine Temp !!

The fact that "A/C is working when driving" is because the moving car is forcing air through the A/C Rad but when stationary the Cooling Fan is needed to do the same job.

I'm assuming that what you are actually doing by applying power is making the Fan run :wink:

Once again, IMHO using the "appropriate Diagnostic machine" :splif: would be able to confirm or refute without spending money on Parts or wasting time changing something that may not be faulty .............
It may be a wiring or relay issue to that Controller, especially if the cooling fan is working at the higher end of engine temps :wink:

HTH, Cheers Dave
 
1 - 11 of 11 Posts
Top