Mercedes SLK World banner

1 - 16 of 16 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
car turns over freely.wont fire, was sitting for over6 months in a parking garage,owner parked it because alarm went off and he could not get it to shut off, he removed the negative battery cable to shut it off,car ran fine till then, now will not fire up.engine turns over, I currently have unplugged number 5 fuse so alarm is off,tried unplugging alarm moduel soon as battery is reconnected alarm goes off.help, I really am puzzled,
 

·
Administrator - Founding Member
Joined
·
92,737 Posts
get a new battery :D
 

·
Administrator - Founding Member
Joined
·
92,737 Posts
how old is your battery? start with that simple thing

get it tested or if you do not know, buy a new one
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
ok battery is at least a year old. and a cheaper quality.i tend to over think problems such as these. I am well versed in alfa romeos but this is a whole new beast. I truly hope it is just the battery.the previous owner is a client of mine and I personally heard the car run befor,
 

·
Administrator - Founding Member
Joined
·
92,737 Posts
battery can have bad cell or cells.
even charging it up will not rejuvenate a dead cell
Our slks need to be used often and desire a great battery. I would think an sl even more so
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
thankyou so much for the advice and it will diffinately be the cheapest place to start. it is a super clean car, just whish it had a standard transmission. I am dying to drive her.
 

·
Registered
Joined
·
866 Posts
car turns over freely.wont fire, was sitting for over6 months in a parking garage,owner parked it because alarm went off and he could not get it to shut off, he removed the negative battery cable to shut it off,car ran fine till then, now will not fire up.engine turns over, I currently have unplugged number 5 fuse so alarm is off,tried unplugging alarm moduel soon as battery is reconnected alarm goes off.help, I really am puzzled,
This car was sitting up for 6 months with no battery connected due to alarm being stuck on. Go ahead check and replace battery if needed (may just need charging) as you will have to do it first any way. Next, if you have an alarm issue then the car will not run (immobilizer) no matter if you unplug this or that. You will have to have the cars ECU scanned for the codes to see what the issue is and it will have to be resolved in order for the car to run again. Could be as simple as resetting a fault or may be an alarm or ECU module issue that will require repair. Also I would really be concerned about the quality of the gas in the car, 6 months is a long time, and I would get some fresh high octane in it for sure.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #10
I have charged the battery numerous times. and after cranking engine 3 or 4 times I notice a very high drop in battery charge,i realize this is a big engine and is gonna require a lot of juice to turn her over, and yes i am questioning the gas quality, I am gonna take the battery out of my ford f 250 to try the battery issue. I could possiably borrow a code reader from one of my friends, arrrg, why could I not be happy just buying shoes and clothes instead of foreign cars.
 

·
Registered
Joined
·
866 Posts
I have charged the battery numerous times. and after cranking engine 3 or 4 times I notice a very high drop in battery charge,i realize this is a big engine and is gonna require a lot of juice to turn her over, and yes i am questioning the gas quality, I am gonna take the battery out of my ford f 250 to try the battery issue. I could possiably borrow a code reader from one of my friends, arrrg, why could I not be happy just buying shoes and clothes instead of foreign cars.
You can go a lot farther in the car than you can in the shoes, and yes you will still need the clothes so just do the clothes and the car (forget the shoes, aint nobody gonna be lookin at em, but the car yes!) and be happy:grin: You a DIY'er? You can get a really good scanner (Autel MD 802 All-System) from Amazon for $175-$200. Pay for itself the first use, you have a 1991 so you will probably need OBD port adapter as well. All the help and links to resources you need right in here:). How much gas is in it? If it is low you can just put some fresh high octane in and it will be fine. As far as the no crank, really need that scanner. I will say from what you described about battery draining after 3 or 4 times of trying to start, really sounds like it has a dead cell. You can have it checked to see if you need a new one. IDK how you gonna use battery from the Ford unless it is same dimensions and CCA. I would just take the battery up and have it checked then if its bad you can go ahead and get a new one and that will be one issue resolved and weeded out:splif:.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
I think I have found the source of my issues ,the becker anti theft module is fried. the circuit board is cooked. charred.am going to find a replacement. now woundering if I am going to have to reprogram security codes once replaced. and what caused it to flame out.
 

·
Registered
Joined
·
866 Posts
hopefully the images of burnt module will load.
Definitely bad alarm module, nice visual work:nerd: Now, have you noticed any discolored wires on the connectors to the module? Any signs of water being the issue? Was any of the fuses for this circuit blown? Could just be the module if none of the above but really need to have look at stored codes in ECU to see if there are any other issues that could be related to or have caused this. This part will most likely need to be coded to communicate with the rest of the car but I m not sure on a 1991 model, may just be newer 2000 and up models. https://mercedespartscenter.com/parts/1991/Mercedes-Benz/500SL/Base?siteid=215720&vehicleid=42365&section=ELECTRICAL&group=BODY ELECTRICAL&subgroup=ANTI-THEFT COMPONENTS&component=CONTROL MODULE
 

·
Registered
Joined
·
11 Posts
Discussion Starter #15
it looks as if just the module is affected no melting of the wireing harness.or connector plug. lets hope that once I get the replacement module all will be ok
 

·
Registered
Joined
·
11 Posts
Discussion Starter #16
i am back.

got a replacement becker autoradio module for the one that was burnt out,alarm no longer goes off but car still wont start,turns over freely, has spark. and fuel at injectors. while trying to start car a low intermittent humming is comeing from the other module,see attached picture, I don't know if this is normal. I also have a replacement for that module as well but no difference if changed. I remember someone saying I may have to have thease programed. desperate to hear this thing run
 

Attachments

1 - 16 of 16 Posts
Top