Mercedes SLK World banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi, first post on this forum!

I have a 2003 SLK230 Kompressor. Whenever it touches 1200rpm either revving up or when the revs come down there is a fairly loud rattle from somewhere in the engine/gearbox.....this happens when driving and also when in P or N. Anyone else experienced this issue?
 

·
Super Moderator UK SLK 55 AMG 2007
Joined
·
28,034 Posts
As it is happening in all gears are you absolutely sure that it is not due to the exhaust?
The system travels underneath the entire length of the car and will echo.
You get the rattle in all gears at the same revs.
Before getting into expense make sure it is not the exhaust.

Another favourite is if any work has been done prior to the rattle,
have any tools been left in the engine bay.

One more quickie for you.
Check the kit stored with the spare tyre. Loose kit often resonates into the cabin.
 

·
Premium Member 2005 SLK55 AMG; 2000 SLK320
Joined
·
210 Posts
In my case on my SLK320 the rattling between 1200 and 1500rpm was down to the front catalytic converters so sounded like it was coming from near the engine. Changed them and now silent.
 

·
Premium Member 2005 SLK55 AMG; 2005 SLK350
Joined
·
5,048 Posts
I had one somewhat similar due to a broken exhaust hangar - it was hard to see the break, and because none of the other hangars was broken you couldn't really see it moving.
 

·
Super Moderator UK 2002 SLK320 Blue
Joined
·
3,065 Posts
I had an exhaust bracket break free on Silkie which was giving a rattle at idle - or just above idle. 30 minutes on the ramp and a spot of welding and no more rattle.

Which reminds me. I need to get some exhaust paint to cover up the bare metal used to earth the welder.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Update...............garage disconnected cam magnet and rattle disappeared.....meaning it's the cam adjusters at fault. Expensive job, so may just leave it as it has got no worse over the past 3 years.....
 

·
Premium Member 1999 SLK 5.4 M113
Joined
·
1,440 Posts
Update...............garage disconnected cam magnet and rattle disappeared.....meaning it's the cam adjusters at fault. Expensive job, so may just leave it as it has got no worse over the past 3 years.....
it's not too expensive if you have a few tools and a "new" part. I've taken mine out, but It wasn't to replace - so I'm not sure on the part prices.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top