Mercedes SLK World banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi SLK friends, My name is Mike in Ohio, I just purchased a BLK ON BLK 05 SLK350 with sports package 2 months ago and I love it...its a dream car to me, UNFORTUNATELY THE SOUND ON MY RADIO AND CD PLAYER STOPPED WORKING ONE DAY, ALTHOUGH THE RADIO SCANS AND THE CD READS ITS PLAYING AND SWITCHES TRACKS...NOT THE END OF THE WORLD, BUT THEN THE NEXT MORNING I TRIED TO START THE CAR AND IT WOULDN'T START... AAA SAID THE STARTER, ALTERNATOR AND BATTERY ARE FINE....THAT THERE MUST BE AN ELECTRICAL SHORT OR SOMETHING THAT IS CONSTANTLY DRAINING THE BATTERY. The car has nav and bluetooth....but they aren't hooked up yet...no disk and no phone module..so I'm not sure if the sound on those are working.Has anyone ever experienced this problem and does anyone have any ideas what I can do or any specific part that I need to replace. I read about possibly needing to reprogram the command center, replacing fuses, a module or amplifier. ANY HELP, SUGGESTIONS AND OR FEEDBACK WOULD BE GREATLY APPRECIATED!!! I miss my car and cant wait to drive it again...especially now that I can put the top down, Thanks, Mike
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,308 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

owner's and maintenance manuals great R171 info:

later year owner's/maintenance/comand manuals, top right in the link below:
Bill's Den: Documents

Lube those seals:
http://www.slkworld.com/226839-post1.html

your brochure:
http://www.slkworld.com/general-discussion/167265-mercedes-brochure-archive.html#post1511249

mods you should do:
smarttop

http://www.slkworld.com/general-discussion/121481-what-smarttop-all-members-keep-talking-about.html

clear or tinted side markers
shorty antenna
led license plate bulbs
led parking lights
carbon fiber on the C pillars http://www.slkworld.com/general-modifications-r171/50849-ive-taken-cf-plunge.html
carbon fiber center caps
oem windscreen or lighted/etched windscreen

See my mod albums for more ideas

FREE GIFT! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). If looking for a car, get the options before you buy!

http://www.slkworld.com/vehicle-data-card/67706-free-how-get-free-datacard.html


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator
 

·
Administrator 2009 SLK 55 AMG/Founding Member 2006
Joined
·
97,308 Posts
Mike, I would start with getting that battery checked again and not by AAA.
See what your starting voltage is.
The slk loves a great battery, not a good battery
Car not starting is your clue.
do you have any idea how old the battery is?

also try a battery reset if you haven't
disconnect the neg cable for a minimum of 30 minutes
reconnect cable
reset clock
synch windows
check your radio for correct operation

oh and comand has only 1 'm'. I will fix for you :D
Cockpit Management and Data system - COMAND for short
 

·
Premium Member 2005 SLK55 AMG
Joined
·
11,405 Posts
Hi Mike, and welcome to SLKWorld.com from the UK Midlands - Thanks for joining us! :)
 

·
Premium Member 2009 SLK55 AMG
Joined
·
11,994 Posts
Welcome from the Sacramento Valley SLK Enthusiasts!
 

·
Registered
Joined
·
2,027 Posts
My personal suggestion is to disconnect the cd changer and replace the head unit with an after market one-buy an adapter so you don't have to screw with wiring. My 05 SLK doesn't have the nav but my 05 e320 does. It's DVD based so it's useless as far as I'm concerned. My phone has GPS of course and it is of course constantly updated.

As far as your car not starting it hardly seems as though a faulty head unit would cause that but hey, after all it is an MB. Check ALL your fuses.

So in short I would: remove or disconnect the OEM stuff to eliminate potential power drain, get your car running again then install an updated head unit.
 
1 - 14 of 14 Posts
Top