Comand has no power - Mercedes Benz SLK Forum

SLK R172 General Discussion Discussion regarding the Mercedes SLK R172

 4Likes
  • 1 Post By jbanks15
  • 1 Post By MartinatMersea
  • 2 Post By Ade's A.M.G.
 
LinkBack Thread Tools
#1 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Comand has no power

Hi all,
I got in my car the other day (250cdi slk) and after a while, I realised the radio wasn't on and the comand screen was blank (not showing any time). I tried switching the car off and back on but still no joy.
I also noticed that no buttons light up when the headlights come on.
I did a bit of digging and tried disconnecting the battery for 30 mins...still no radio but now all the writing on the dash is in German!
I've checked all the fuses in the engine bay and in the boot and none are blown...I've also checked the one in the back of the radio itself and that is not blown either...
Any one got any ideas????
Ade's A.M.G. is offline  
Sponsored Links
Advertisement
 
#2 Old 2 Weeks Ago
Premium Member
 
i860's Avatar
 
Join Date: Dec 2013
Location: Dorset
Vehicle: SLK 350 R171 2004
Other Toys: Mercedes W204 C280 Elegance
Posts: 3,486
Country:
Chats: 0
Mentioned: 414 Post(s)
Tagged: 2 Thread(s)
Quoted: 859 Post(s)
Thanks: 78
Thanked 613 Times in 541 Posts
Check the fuses inside the car, left side.

Remote installation of Passthru, C4 DAS/Star Mercedes, XENTRY,EPC/WIS
i860 is online now  
#3 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Thanks for the reply...where on the left side?
Ade's A.M.G. is offline  
 
#4 Old 2 Weeks Ago
Super Moderator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 89,558
Country:
Chats: 38
Mentioned: 428 Post(s)
Tagged: 5 Thread(s)
Quoted: 6352 Post(s)
Thanks: 3,209
Thanked 10,887 Times in 8,258 Posts
Quote:
Originally Posted by Ade's A.M.G. View Post
Thanks for the reply...where on the left side?
https://www.slkworld.com/339803-post6.html
MartinatMersea likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#5 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
I've looked all over the dash and there is no interior fuse box that I can find...
Any other ideas???
Ade's A.M.G. is offline  
#6 Old 2 Weeks Ago
Premium Member
 
MartinatMersea's Avatar
 
Join Date: Mar 2016
Location: Mersea Island Essex & Goonhavern Cornwall
Vehicle: 2012 SLK55, Iridium Silver, Bengal Red Leather. Sold 2010 SLK350 Obsidian Black
Other Toys: Volvo 480 Turbo, Various Gadgets
Posts: 4,446
Country:
Chats: 0
Mentioned: 123 Post(s)
Tagged: 0 Thread(s)
Quoted: 333 Post(s)
Thanks: 104
Thanked 405 Times in 301 Posts
Garage
Quote:
Originally Posted by Ade's A.M.G. View Post
I've looked all over the dash and there is no interior fuse box that I can find...
Any other ideas???
Look at @jbanks15 link in his post 4. The fuse you want is located in the engine compartment drivers side at the rear ( Fuse 26 which is 20Amp rating). @i860 is referring to the R171 of the SLK which is not the same location as the R172.
jbanks15 likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Martin

Mods:
CKS Bonnet/Hood Fins
AMG Grill Badge
STHFMZ2 SmartTop v1.52
MartinatMersea is offline  
#7 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
I've checked that fuse, and swapped it with another 20 amp just to be sure but still nothing...😥

It's the yellow one in the middle on the right...
Attached Images
File Type: jpg 20190627_185005_1561660812691.jpg (43.8 KB, 6 views)
Ade's A.M.G. is offline  
#8 Old 2 Weeks Ago
Premium Member
 
Windinmyhair's Avatar
 
Join Date: Sep 2017
Location: Cotswolds
Vehicle: 2014 SLK r172 200AMG blue efficiency petrol Auto
Other Toys: Lots of tools
Posts: 1,508
Country:
Chats: 0
Mentioned: 22 Post(s)
Tagged: 0 Thread(s)
Quoted: 316 Post(s)
Thanks: 54
Thanked 126 Times in 121 Posts
Connector fallen out the back of the unit? Anyone been rootling around back there at any time?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Windinmyhair is online now  
#9 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
No one been messing...just didn't come on one day...when I checked the fuse in the back of the radio, I had to disconnect the plug...which locks in place...and I relocked it...
It's a mystery....any one near cannock with "star"?...or can reccomend someone....
Ade's A.M.G. is offline  
#10 Old 2 Weeks Ago
Premium Member
 
i860's Avatar
 
Join Date: Dec 2013
Location: Dorset
Vehicle: SLK 350 R171 2004
Other Toys: Mercedes W204 C280 Elegance
Posts: 3,486
Country:
Chats: 0
Mentioned: 414 Post(s)
Tagged: 2 Thread(s)
Quoted: 859 Post(s)
Thanks: 78
Thanked 613 Times in 541 Posts
If the unit has no power xentry will not help you...

Remote installation of Passthru, C4 DAS/Star Mercedes, XENTRY,EPC/WIS
i860 is online now  
#11 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Oh no!...has anyone got a wiring diagram for the radio...might try to get some power to it to establish if its goosed or not...
Ade's A.M.G. is offline  
#12 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Just put my torque fault code reader on and got a
'UO164-network' code...any ideas anyone?
Ade's A.M.G. is offline  
#13 Old 2 Weeks Ago
Premium Member
 
MartinatMersea's Avatar
 
Join Date: Mar 2016
Location: Mersea Island Essex & Goonhavern Cornwall
Vehicle: 2012 SLK55, Iridium Silver, Bengal Red Leather. Sold 2010 SLK350 Obsidian Black
Other Toys: Volvo 480 Turbo, Various Gadgets
Posts: 4,446
Country:
Chats: 0
Mentioned: 123 Post(s)
Tagged: 0 Thread(s)
Quoted: 333 Post(s)
Thanks: 104
Thanked 405 Times in 301 Posts
Garage
Have you jump started your car or connected a charger with the polarity round the wrong way? On my wife's Honda CRV somebody did this and afterwards the Head Unit was completely dead. None of the car external fuses had blown. However, after a trip to the Honda Dealer to diagnose, an internal fuse within the Head Unit itself had blown. Problem solved.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Martin

Mods:
CKS Bonnet/Hood Fins
AMG Grill Badge
STHFMZ2 SmartTop v1.52
MartinatMersea is offline  
#14 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
No charger been connected...just got in one day and no radio...😥
Ade's A.M.G. is offline  
#15 Old 2 Weeks Ago
Registered Users
 
Ade's A.M.G.'s Avatar
 
Join Date: Sep 2018
Location: Cannock
Vehicle: 2012 slk 250 AMG sport.
Other Toys: A wife and an A class.
Posts: 40
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Finally...fixed!...today I decided to try and find out why the radio wont come on.
I went out this morning and in 32 degree heat started stripping the car.
I got the radio out...could only find 1 live wire (permanent)...no ignition live and no live when the lights were on...the internal fan was running though...tried following the wires and they run under the centre console to the back...I got in the boot and checked all the fuses (again!)...none gone...took the end panel off the dash and got my hand in and 'wobbled' whatever wires I could touch...still nothing...next was the fuse box under the bonnet..I started to take this out and noticed that where its screwed in, there are sort of anti tamper plastic shrouds and 1 was broken...someone has been here before I thought...I tried to lift the fuse box out but it would only come so far...I looked underneath it and just saw a mass of wires..because I was getting frustrated and was hot I'd had enough so I 'wobbled' it around a bit and put it back...thought I'd see if anything had happened...low and behold...radio on!!!😃
At least if it goes off again I know where to look....
Time for beer!!🍻
Windinmyhair and Sgooter like this.
Ade's A.M.G. is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R172 SLK Class Cars > SLK R172 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.